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About This Book

Subject

Audience

This book contains step-by-step tutorials for the PowerDesigner
DataArchitect data modeling environment. It shows you how to do the
following:

+ Build a Conceptual Data Model (CDM) and a Physical Data Model
(PDM)

¢ Use business rules and other model objects

+ Generate triggers, procedures, extended attributes, scripts, and databases

This book is for anyone who will be building data models with
PowerDesigner DataArchitect. Some familiarity with relational databases,
SQL, and design methodology is helpful, but not required.

Vii



PART ONE

CDM Tutorial

This part is an introduction to the DataArchitect conceptual data modeling
environment.



CHAPTER 1

About the CDM Tutorial

What is a CDM?

Why build a CDM?

This tutorial is a series of eight lessons in which you learn how to use
DataArchitect to build a Conceptual Data Model (CDM).

In this tutorial, you complete the CDM delivered in the tutorial file. This
model is based on a real-life example of an information system. It provides a
context for the exercises. As you build onto this model, you learn how to
create all the basic elements of a CDM. You can then apply your knowledge
to creating a CDM to suit your needs.

A CDM represents the overall structure of an information system. It describes
the conceptual relationships of different types of information rather than their
physical structures. A CDM is independent of a particular database
management system (DBMS).

In a CDM, you can put design issues first because you do not have to worry
about the details of physical implementation. You deal principally with
entities and their relationships. These are easy to understand and to
manipulate.

Through a simple generation procedure, you can transfer the solid design
framework of the CDM to the Physical Data Model (PDM). The PDM adapts
your design to the specifics of a DBMS and puts you well on the way to
complete physical implementation.



What you will do

What you will do

Chapter 2 You begin by preparing a business description and stating the business
problems to solve. You will refer to this statement in order to decide what
business rules, data items, and entities you need to create.

Chapter 3 You will start DataArchitect and open the tutorial CDM. This CDM presents
the conceptual structure of a publishing enterprise.

You will specify model preferences and properties, then save the model
under a new name.

Chapter 4 You will create business rules, domains, and data items to complete the
CDM. Next, you will apply check parameters to a domain.

Chapter 5 You will add entities to the tutorial model. You will define entity attributes
and designate an identifier. You will also attach a business rule to an entity.

Picture MNonperiodical Periodical
Picture 1D Book collection Periodical Forrmat
Picture Periodical Pub Frequency
Chapter 6 You will create relationships between entities. You will create relationships

with different cardinalities, as well as mandatory and dependent relationships.

Author
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Author First Mame
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Author Advance
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Author Phone Mumber
o
is Shnlwn in
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Picture
Picture ID
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Chapter 1 About the CDM Tutorial

Chapter 7 You will create a submodel to which you will add entities.

Chapter 8 You will create an inheritance link using the entities in the submodel.

Title
Title ISBMN
Title Text
Title Type
Title Price
Title Motes
Title Publication Date

Monperiodical Periodical
Book collection Periodical Format
Periodical Pub Freguency

Chapter 9 You will use the display options and tools to organize the model. You will
insert a title box and change its color. You will use the alignment tools to
align symbols and straighten relationship lines.

Conceptual Data Model
Project : Publications Royalty Schedule
Model : Tutorial Royalty Low Range
Author @ user |Ve|sion: 10 |‘1‘1.l‘25!95 .Oﬂ/ Royalty High Range
EPPHES to  |Foyalty Amount
Title has
Title ISEN - Publisher
TitleAuthor Title Taxt is published by Publisher ID
TitleAuthar Order {=o—t— Title Type W Publisher Mame
Titleduthar Percent Title Price publishes City
Title Motes . State
Title Publication Date is sold
correspand to Sale
Author Sale Invoice 1D
Author IO Sale Date
Author Last Marme Sale Amount
Author First Narme Sale Terms_
Author Biography Sale Quantity
Author Advance Manperiodical Periodical
Author Address Book collection | |Periodical Forrmat .
City Periodical Pub Freguency takes place in
State
Postal Code
Authar Phone Number
is shown in Discount Store
! - Stare 1D
h Discount 1D r—
snows . Stare Mame
%\ Digcount Percent o1 City
Ficture Discount Type is given tozs | gyaig
- Lo Cluantity
Picture |0 High Cluantit Paostal Code
Picture g Y Store Address




What you will do

Chapter 10 You will generate a Physical Data Model (PDM) from the CDM. You will
define the generation parameters, generate the PDM, then save and close the
PDM.

How long it will take

You can do the CDM tutorial in one sitting in about 1% hours.

You can do the entire tutorial in about 2% hours. You can stop after any
chapter and continue at another time.

What you will learn

You will learn basic DataArchitect techniques for creating a CDM, including:

¢ How to create the basic elements of a CDM: domains, data items,
business rules, and entities

How to create different types of relationships between entities
How to create submodels and add objects to a submodel

How to create an inheritance

* & o o

How to use the display functions to arrange symbols and to center the
model on the page

*

How to create submodels and add objects to a submodel

+ How to generate a Physical Data Model (PDM) from a CDM



Chapter 1 About the CDM Tutorial

Setting up

Before you begin, make sure that the files you need for the exercises are on
your hard disk. When you install DataArchitect, these files are installed in

subdirectories of your PowerDesigner directory. When you have finished
with this tutorial you can delete them if you want.

The CDM tutorial uses the following files:

File Subdirectory Description

CDMBEFOR.CDM | PD6\EXAMPLES | Starting tutorial CDM

CDMAFTER.CDM | PD6\EXAMPLES Finished tutorial CDM




CHAPTER 2
Stating the Business Problem

The first step to creating a Conceptual Data Model (CDM) is to formulate a
statement of the business problems that the CDM will address. To do this,
you draw up a description of business activities. This helps you decide:

¢ What information you need to store
¢ What entities are involved in the business

+ How the business operates

When the way the business operates is clear, you can begin to develop the

CDM.
Business You will start this tutorial with a CDM that is the conceptual model of the
description information system for a publishing company.

A business description indicates that the entities involved in the business
include titles, authors, book stores, and discounts. It indicates the details
related to each of these entities: from international standard book numbers
(ISBN) for titles to store addresses.

Business problem In the course of the CDM tutorial, you will solve three business problems:

¢ Royalties for multiple authors Keep track of different royalty
percentages for authors of the same book

¢ Author pictures and biographies Identify and store author pictures
and biographies for use on book covers

+ Title categories  Classify each title as a periodical or a non-periodical
and save related information

On the basis of these business problems, you will extend the tutorial model to
manage additional data. For example, you will add an entity for pictures and
you will create a data item to store information about percentages of royalties
that a particular author receives.



CHAPTER 3

How to Begin the CDM Tutorial

You will begin the tutorial by running DataArchitect. You will learn how to
use the tool palette.

You will open the tutorial file and assign it preferences, options, and
properties. Next, you will save it under a different name so that you can go
back and use the original model again if you want to repeat the exercises.

In this chapter you will:

*

* & & o o

Start DataArchitect

Use the tools in the tool palette
Open the tutorial CDM

Define CDM preferences and options
Define CDM properties

Save the tutorial CDM

How long will it take?
About 10 minutes.

11



Start DataArchitect

Start DataArchitect

Where you are
Chapter 3 How to Begin
® Start DataArchitect
Use the tools in the tool palette
Open the tutorial CDM
Define CDM preferences and options
Define CDM properties
Save the tutorial CDM

E' 1 Click the DataArchitect program icon.

The DataArchitect window appears. It contains an empty CDM
workspace, and the CDM tool palette.

The DataArchitect window has a menu bar across the top. The menu bar
gives you access to all the management functions.

PowerDesigner DataArchitect - [ CDM Model 1 ] [ O] X]

Eile Edit Dictionary Amange Format Yiew  Window  Help _|5’|i|

Dis|ais] &|m|@| 2|dw|Fl o e =)o) w0 E_II

WEAEERIE
>
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Chapter 3 How to Begin the CDM Tutorial

Your screen looks different

All the screen captures in this book were taken in a Windows 95
environment, with an 800x600 screen resolution. The appearance and
proportions of the images which appear on your screen may be
slightly different.

13



Use the tools in the tool palette

Use the tools in the tool palette

Where you are
Chapter 3 How to Begin
Start DataArchitect
® Use the tools in the tool palette
Open the tutorial CDM
Define CDM preferences and options
Define CDM properties
Save the tutorial CDM

The buttons in the CDM tool palette enact all major functions needed to build
and modify a CDM.

Tools

i€

x
i

>\
e
N E
Ol

&

IO 6"k

P

1
a

B

PDM tool palette

The Physical Data Model (PDM) tool palette is almost identical. In the
PDM tool palette, tools for creating PDM objects replace the tools for,
creating CDM objects.

The following table indicates the names of all tools in the tool palette.

Tool | Name Action

Pointer Select symbol

Lasso Select symbols in an area

@l Grabber Select and move all symbols
Zoom Select a zoom area

Zoom in Zoom in (increase view scale)
,:¢| Zoom out Zoom out (decrease view scale)
Scissors Delete symbol

14



Chapter 3 How to Begin the CDM Tutorial

Tool | Name Action

Entity Insert entity symbol

Relationship| Insert relationship symbol

<l
Inheritance | Insert inheritance symbol

Property Display object property sheet

El Text Insert text

Line Draw a line

@ Rectangle Draw a rectangle

@l Oval Draw an oval

@ Rounded Draw a rounded rectangle
rectangle

Polyline Draw a jagged line

@ Polygon Draw a polygon

So that you know how to use these tools before you begin creating the CDM,
you will create a few objects using the tool palette.

1 Click the Entity tool in the tool palette.

The cursor takes the form of an entity.

2 Click anywhere in the CDM workspace.

An entity symbol appears at the click position. The entity has the name
Ent_n, where n is a number assigned to the entity in the order of creation
of objects.

Ent_1

15



Use the tools in the tool palette

R

16

The Entity tool is still active, so click again in the CDM workspace to
create another entity.

There are now two entities in the CDM workspace.

Ent_1 Ent_2

Click the Relationship tool in the tool palette.

The Entity tool is now released and the Relationship tool is active.

Click inside the first entity.
Drag the cursor to the second entity.
Release the mouse button inside the second entity.

This creates a relationship.

Ent_1 Ent_2

Relation_3

Click the right mouse button to release the Relationship tool.

To release a tool
A tool remains active until you release it. You can release a tool, by
selecting another tool or by clicking the right mouse button. By
default, the Pointer tool is selected.

Double-click the Entity tool in the tool palette.

This selects all the entities. Handles appear on the entities to show that
they are selected.

Ent_1 Ent_2

Relation_3

Selecting all objects of a particular type
You can select all objects of a particular type by double-clicking the

corresponding tool in the tool palette. You can select all objects af all
types, by double-clicking the Pointer tool.
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10

11

12

13

14

Drag the entities to a new position.

The relationship moves with the entities.

Click the Text tool in the tool palette.

The cursor takes the form of an | beam.

Click the CDM workspace.

A text box appears.

Type a short text into the text box.

&I p ||@I Cancel |

These bwo entities are related)] ﬂ

-
4 F

Click OK.
The text appears in the CDM workspace.

Ent_1 Ent_2

oo
Relation_3

These two entities are related.

Click the Pointer tool in the tool palette.

You will use this tool to select and delete one of the objects.

Click one of the entity symbols.
This selects the object you want to delete.

17



Use the tools in the tool palette

15 Press the DEL key.

The Confirm Deletion in the Global Model message box appears asking
you how you want to delete the selection.

Confirm Deletion in the Global Model

@ How do you want to delete the selected spmbol?

& Delete this symbol and associated object

' Detach this symbol anly

Cancel |

Deleting objects
If you select Delete Symbols and Associated Objects, you erase the
graphic symbol and delete the definition of the object from the
dictionary. If you select Detach Symbols Only you erase the graph
symbol, but keep the definition of the object in the dictionary.

c

16 Click OK.

The entity and associated relationship are removed from the CDM. Their
definitions are deleted from the dictionary.

17 Double-click the Pointer tool in the tool palette.

This selects the remaining entity and the text.

18 Press the DEL key and click OK when the deletion message appears.

The remaining entity and the text are erased.

18



Chapter 3 How to Begin the CDM Tutorial

What you learned

In this section, you learned how to use some of the tools in the tool palette.
You now know how to:

*

*

* & o o

Select a tool

Release the active tool either by selecting another tool or by clicking the
right mouse button

Select all objects of a particular type
Move graphic objects
Create text to document the CDM

Delete objects

19



Open the tutorial CDM

Open the tutorial CDM

Where you are
Chapter 3 How to Begin
Start DataArchitect
Use the tools in the tool palette
®» Open the tutorial CDM
Define CDM preferences and options
Define CDM properties
Save the tutorial CDM

To perform the rest of the tutorial, you must open the tutorial file.

1  Select File>Open.

A file selection window appears.

2 Goto the EXAMPLES directory.
Select the COMBEFOR.CDM file.
Click OK.

DataArchitect displays the model in the CDM workspace.

20



Chapter 3 How to Begin the CDM Tutorial

3 If you can only see part of the model, click the Zoom All tool in the toolbar

that runs across the top of the window.

This displays the whole model in the CDM workspace. The model may
not look exactly like the one shown below.

Royalty Schedule
Royalty Low Range
Royalty High Range
applies to | Royalty Amount
—

Title has
Title ISEN L Publisher
is written by | Title Text is published by , [Publisher 1D
Title Type f=0——————+— Publisher Mame
Title Price publishes | oy,
. Title Notes M, State
wiites Title Publication Date i =sold
correspond to Sale
Author Sale Invoice 10
Author 10 Sale Date
Author Last Barme Sale Amount
Author First Name Sale Terms
Authar Advance Sale Cluantity
Author Address
City _
State takes place in
FPaostal Code
Authar Phone Mumber
Store
Discount Stare D
Discount Id i= given tq__ Store Mame
Discount Percent 520 Gives | City
Digcount Type State
Lovw Quantity FPastal Code
High Quartity Store Address

Adjust display scale

You can choose the display scale most comfortable for your eyes, by
selecting View-Scale and choosing a scale.

21



Define CDM preferences and options

Define CDM preferences and options

Where you are
Chapter 3 How to Begin
Start DataArchitect
Use the tools in the tool palette
Open the tutorial CDM
=® Define CDM preferences and options
Define CDM properties
Save the tutorial CDM

Before you begin working, you will define certain display preferences and
model options for the CDM.

&~ For a complete description of all CDM preferences and options, see
PowerDesigner DataArchitect User's Guide

1  Select File>Display Preferences from the menu bar.

The Display Preferences dialog box appears.

2 Select or clear checkboxes and radio buttons so that the dialog box looks
like the one shown below.

Dizplay Preferences

General | Symbolsl Mame & Codel

¥ Auto-adiust to best ™ Eeep center ™ Keep aspect ratio
™ Printer fonts Page scale: |1DD %
Digplay: @ Name Code

— Entity

¥ ldentifiers W Other attibutes ™ Domains

— Relationzhip

[~ Mame ¥ Role

ak I Cancel | Help |

These preferences display object names, entity identifiers, entity
attributes, and relationship roles. They adjust entities to fit their text.

22



Chapter 3 How to Begin the CDM Tutorial

6

Click OK.

Select File>Model Options from the menu bar.

The Model Options dialog box appears.

Select or clear checkboxes and radio buttons so that the dialog box looks

like the one shown below.

Model Dptions

General | Namel Codel Editorl

— Data ltem / Domain

™ Enforce

Use: [ Datatype
" Check
™ PRules

Data [kem
¥ Unique code
7 Allow reuss
Default add option:
& Beuse © Duplicate

— Default Data Type

Relationship
¥ Unigue code

ol ol ol

[<UNDEF> ]
Delete options
V' Confim
Cancel Help
Click OK.

23



Define CDM properties

Define CDM properties

Where you are

Chapter 3 How to Begin

Start DataArchitect

Use the tools in the tool palette

Open the tutorial CDM

Define CDM preferences and options
» Define CDM properties

Save the tutorial CDM

1  Select Dictionary>Model Properties from the menu bar.

The Model property sheet appears.

Model Properties [ %]

Definition | Descriptionl Annotationl

Project name: |

Project code: I

Mame: IB tarting COM for butarial
Code: |COM_BEFOR
Label: I

Authar: | Wersion: l—
Language: I English [United States) j

File: C:\Pw RS WPDBAE wamples.cdmbefor. cdm

Created:  3/25/97 5:20 PM Modified: 3/27/97 10:58 AW

Lo Lo (o e

ak I Cancel | Aoy Help

2 Type Publications in the Project Name box.

This is the name of the project to which the CDM belongs.

3 Click the j button at the end of the Project Code box.

This sets the code equal to the name.

24



Chapter 3 How to Begin the CDM Tutorial

4 Type Tutorial in the Name box.
This is the name of the CDM.

5 Click the J button at the end of the Code box.

This sets the code equal to the name.

6  Type your name in the Author box.

This indicates that you are the owner of the CDM.

7 Type 1.0 in the Version box.
This indicates that this is the first version of the CDM.

Model Properties [ %]

Definition | Descriptionl Annotationl

Project name: |Publications j
Project code: IF'UBLID’-\TIDNS j
Mame: IT utarial j
Code: [TUTORIAL =
Label: I

Authar: |user Wersion: I‘Id—

Language: IEninsh [United States) j

File: C:\Pw RS WPDBAE wamples.cdmbefor. cdm

Created:  3/25/97 5:20 PM Modified: 372797 10:58 AM

ak I Cancel Apply Help

8 Click OK.

25



Save the tutorial CDM

Save the tutorial CDM

Where you are
Chapter 3 How to Begin
Start DataArchitect
Use the tools in the tool palette
Open the tutorial CDM
Define CDM preferences and options
Define CDM properties
®» Save the tutorial CDM

You will save the tutorial CDM in another file. This leaves the original
tutorial CDM intact so you can use it again if you want to redo the exercises.

1  Select File»Save As.

The File Save As dialog box appears.

2 Type TUTORIAL.CDM in the File Name box.

This is the name of the file in which you will work and save your
modifications.

3 Click OK.
This saves your model in the TUTORIAL.CDM file.

Save your work
Save your work periodically while doing these exercises by selec
File>Save.

ng
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CHAPTER 4

Defining Business Rules, Domains, and
Data ltems

About business A business ruleis a written expression of the way a business operates. When
rules you create a business rule, you refer to the ideas set out in the business
description.
There are four types of business rules: facts, definitions, formulas and
validations:
Type of
business rule  |Example
Fact A publisher may publish one or more titles
Definition An author is identified by a name and an address
Formula The amount of royalties is a percentage of the sales which

increases according to the amount of sales

Validation The percentage of royalties paid to all authors of a book must
add up to 100% of the royalties

When you use business rules to document the CDM, they are not translated
into executable code. You will see the ways in which you can implement
business rules later, in the PDM part of the tutorial.

About data items A data itemis an elementary piece of information. For example, this CDM
contains data items for author last name and for book titles.

About domains A domain defines a standard data structure that you can apply to multiple
data items. When you modify a domain you globally update the data items
associated with the domain. This makes it easier to standardize data
characteristics and modify your model consistently when you need to make

changes.
About check Check parametersspecify more precisely what values to allow for a domain
parameters or a data item. In a CDM, check parameters define standard parameters, such

as minimum, maximum, or accepted values.

27



Create a new business rule

What you will do In this chapter you will:

+ Create a new business rule
Create a new domain
Create a new data item

Attach a data item to a domain

* & o o

Attach a check parameter to a domain

How long will it take?
About 20 minutes.
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Create a new business rule

Where you are

Chapter 4 Defining Business Rules, Data Items, and Domains
®» Create a new business rule

Create a new domain

Create a new data item

Attach a data item to a domain

Attach check parameters to a domain

You will create a business rule that states how to attribute royalties to
authors.

1  Select Dictionary>List of Business Rules.

The List of Business Rules dialog box displays existing business rules.

2  Click New.

An arrow appears at the beginning of the first blank line.

List of Business Rules E
Mame | Cods | Type E|U|N|i|
1 |Advance ADWANCE Farmula ECFT
2 |buthor Sales AUTHOR_SALES Fact BT~
3 |Royalies ROTALTIES Formula ECFC
4 [Royaly Ranges ROTALTY_RANGES Validation  [#TF T
B |Sales in Stores S4LES_IN_STORES Defirition  [#T [ [

+ E Defirition  [®C T [T
Delete | ﬂil_blil Sortby: ¢ Name & Code
Label: I

Define | Attach | QK | Cancel Help

3 Type Author Percent in the Name column.

This is the name of the business rule.
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Create a new business rule

4 Click the Code column.
Click the J button that appears in the Code column.

This sets the code equal to the name, with lowercase characters replaced
by uppercase, and the space replaced by an underscore.

Using the keyboard
You can also move to the next column in a list dialog box by pressing
TAB. If the cursor is in the Name or Code column, you can press

select thd button.

5 Select Validation from the dropdown list in the Type column.

Lizst of Business Rules [ %]
Name | Code | Type E[un] =]
1 JAdvance ADYANCE Formula (i
2 lauthor Sales AUTHOR_SALES Fact E3(i
3 |Riopalies ROYALTIES Formula BCF
4 |Ropaky Rarges ROYALTY_RANGES Validaton [T P [
5 |Salesin Stores S4LES_IN_STORES Definition ECF T
& |&uthor Percent AUTHOR_PERCENT i alidation rrr
New | Delete | | <] [ r] Sorthy: © Name & Code
Label: I

Define | Attach | QK. I Cancel | Help

This defines the business rule as a validation rule.

6  Click the Define button in the bottom part of the dialog box.

The Business Rule Definition dialog box appears.
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7 Inthe Description box, type The percentage of royalties paid to all authors of a
book adds up to 100% of the total royalties.

This text explains the meaning of the business rule.

Mame: [Euthor Percent _=| tode [EUTHOR_PERCENT [-
Tvpe: W Label: I

Diescription:

Theltp_ecentage of ropaltiez paid ta all authors of a book adds up to 100% aof the tatal ;I
roalties

Expression; ¢ Clisnt % Server

-
Zoom |anotate| Attach | ak I Cancel | Help |

8 Click OK in each of the dialog boxes.

This validates creation of the business rule.

Business rules sorted alphabetically
When you close the list of business rules, the business rules are jsorted
alphabetically. The order of appearance of the business rules wil
therefore be different next time you open the list.

What you learned In this section, you learned how to:

+ Use the statement of the business problem to create the description of the
business rule

¢ Create a business rule

+ |dentify a business rule by a name, a code, and a type
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Create a new domain

Create a new domain

Where you are
Chapter 4 Defining Business Rules, Data Iltems, and Domains
Create a new business rule
= Create a new domain
Create a new data item
Attach a data item to a domain
Attach check parameters to a domain

You will create two domains that will define a standardized data type for
money amounts and for percentages in the model.

1 Select Dictionary>List of Domains from the menu bar.

The List of Domains dialog box displays the existing domains.

2  Click the New button.

An arrow appears at the beginning of the first blank line.

List of Domains
Mame | Cods | Data Type | o] | N ILI
2 |pate DATE D M
(4 [Mumeric |dentifier IDENTIFIER sl =l
5 |Long_notes LONG_MOTES =T il
[ Long tew LOMG_TEXT A0 il
7 [Mames MAMES a4l M
8 [Quantiy BUANTITY N M-
19 [Shart_test SHORT_TEXT a2l FI
10 fres no YES_MO BL Imln
EX E 0

Delete | ﬂﬂﬂﬂ Sotby: ¢ Mame & Code

Label: I

Check I Desgribel Anno_tatel Wzed B-"'l ak | Cancel | Help |

3 Type Amount in the Name column.

This is the name of the domain.
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Click the Code column.
Click the J button that appears in the Code column.

This sets the code equal to the name, with lowercase characters replaced
by uppercase.

Click the Data Type column.
Click the =] button that appears in the Data Type column.

The Standard Data Types dialog box appears. You use this dialog box to
specify the form of the data affected by the domain.

Using the keyboard
If the cursor is in the Data Type column, you can open the Standard
Data Types dialog box by pressipg}

Click the Money radio button.

The domain now has a money data type. A money data type stores
numbers with a fixed decimal point. Later, when you apply this domain
to the data items that are used to store amounts of money, you will see
that they inherit this data type.

Data type codes
All data types have a one, two, or three letter code. When you select
the Money radio button, MN appears in the Code box. This is the
code for a money data type.

Type 8 in the Length box.

The maximum number of figures in a data item attached to this domain
will be 8.
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Create a new domain

8 Type 2 in the Precision box.

A data item attached to this domain can take two positions after the
decimal point.

Standard Data Types
' Integer ' Characters " Binary
© Shart inkeger W aiiable characters = Long binary
' Lang integer € Lonhg characters
 Bpte £ Long var characters
" Number © Tent " Bitmap
' Decimal © Multibyte " Image
" Float £ ariable multibyte " OLE
" Short float -
© Lang float © Date
& Maney  Time = Other
 Serial  Date & time " Undefined
" Boolean © Timestamp
Code: IMN— Length: IB— Precision: |2_
oK I Cancel | Help |

9 Click OK.

You return to the list of domains. The value MN8,2 appears in the Data
Type column. MN is the code for a money data type. Eight indicates that
an amount of money can have 8 figures. Two indicates that the amount
has a decimal precision of 2.

List of Domains
Mame | Cods | Data Type | o] | N ILI
3 |Date DATE D =
4 |Mumeric | dentifier IDENTIFIER ] M=
5 |Long_notes LONG_MOTES =T il
f |Long_text LOMG_TEXT A0 il
7 |Names MAMES ] =
8 |Quartity QUANTITY M =
9 [Short_test SHORT_TEXT Wa20 =
10 [ves no YES_MO BL Imln
=+ |amount AMOUNT IREE Err -

Mew | Delete | ﬂﬂﬂﬂ Sotby: ¢ Mame & Code

Label: I

Check I Desgribel Anno_tatel Wzed B-"'l ak I Cancel | Help |
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10

11

12

13

14

Click the New button.

An arrow appears at the beginning of a blank line.

Type Percent in the Name column.

This is the name of the domain.

Click the Code column.
Click the J button that appears in the Code column.

This sets the code equal to the name, with lowercase characters replaced
by uppercase, and restricted characters (such as spaces) replaced by
underscores.

Click the Data Type column.
Click the =] button that appears in the Data Type column.

The Standard Data Types dialog box appears.

Click the Short Integer radio button.

The code Sl indicates that the Percent domain has a short integer data
type. The Length and Precision boxes are not available because you do
not need to specify a length and precision for the short integer data type.

Standard Data Types
" Integer © Characters " Binary
o " Wariable characters " Long binary
" Long integer & Lang characters
" Byt " Long var characters
© Mumber © Teut " Bitmap
" Decimal © Multibyte " Image
" Float W ariable multibyte " OLE
" Short float
© Long float  Date
" Money © Time " Other
© Serial  Date & time " Undefined
" Boolean © Timestamp
Code: ISI— Length: I— Precizion: I_
aK I Cancel I Help |
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15 Click OK.

You return to the list of domains.

List of Domains
Name | Code | DataTwpe [U[N]a]
4 |Numeric Identifier IDENTIFIER: gl =
5 |Long_notes LOMG_NOTES T=T =
B |Long test LOMG_TEXT A0 =
7 |Mames MAMES V40 =
B [Quantiy QUANTITY N M=
9 [Short_text SHORT_TEXT WAz il
10 [res_no YES_MO BL rr
11 |dmount AMOUNT MMBE.2 rr
+ |Percent PERCENT g Err =

Mew | Delete | ilil_blll Sortby: ¢ Name ¢ Code

Label: I

Check | Desgribel Anno_tatel sed Byl 0k I Cancel | Help |

Default data type

When you do not define a data type for a domain, it receives the
default data type. You can designate a default data type by selecting
File>Model Options.

16 Click OK.
This saves the definition and returns you to the model window.
What you learned In this section, you learned how to:

+ Look for data items storing similar types of data, and create a domain to
standardize the data characteristics of these data items

+ |dentify a domain by a name and a code

+ Specify the data type, length, and precision of the domain
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Create a new data item

Where you are
Chapter 4 Defining Business Rules, Data Items, and Domains
Create a new business rule
Create a new domain
®» Create a new data item
Attach a data item to a domain
Attach check parameters to a domain

To manage books with multiple authors, you will create data items for the
percentage of royalties for each author and for the order of an author's name
in the list of authors.

1 Select Dictionary>List of Data Items from the menu bar.

The List of Data Items displays existing data items.

2  Click the New button.

An arrow appears at the beginning of the first blank line.

List of Data ltems [ x|
Dizplay Dataitems:  ( Uged € Uruged & Al Display entity:  Mame (¢ Code
Name | Code | Entity I Data Type |U | N |:|
33 [Store ID STOR_ID STORE 12 |2
3 [Store Name STOR_MAME STORE W40 il
35 |Tile ISEN TITLE_ISEN TITLE £12 FI
36 |[Title Motes TITLE_NOTES TITLE =T il
37 |[Title Price TITLE_PRICE TITLE MNE.2 ol
38 |Tile Publication Date  TITLE_PUBDATE TITLE ] ¥
33 |[Title Text TITLE_TEXT TITLE WA =
40 [Title Type TITLE_T*PE TITLE W20 il
> rr-
New Delete | |q| < | » | >|| Sartby: € Mame (% Code  Enfity
Label: I
Domain: I[None] j J
Check | Describe | Annotate | Entity | QK. | Cancel | Help |

37



Create a new data item

38

Type TitleAuthor Percent in the Name column.

This is the name of the data item.

Type TA_PERCENT in the Code column.

The Entity column

The Entity column indicates the entity to which each data item
belongs. This column is empty because the new data items are npt yet
associated with entities.

Select Percent from the Domain dropdown listbox in the bottom part of the
dialog box.

This applies the data type of the Percent domain to the new data item. In
the Data Type column, Sl indicates a short integer.

Click the New button.

An arrow appears at the beginning of a blank line.
Type TitleAuthor Order in the Name column.
Type TA_ORDER in the Code column.

Click the Data Type column.
Click the j button that appears in the column.

The Standard Data Types dialog box appears.
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10 Click the Integer radio button.
This gives the TitleAuthor Order data item an Integer data type.

Standard Data Types
i ' Characters " Binary
© Shart inkeger W aiiable characters = Long binary
' Lang integer € Lonhg characters
 Bpte £ Long var characters
" Number © Tent " Bitmap
' Decimal © Multibyte " Image
" Float £ ariable multibyte " OLE
" Short float
© Lang float © Date
" Maoney  Time = Other
 Serial  Date & time " Undefined
" Boolean © Timestamp
Code: II— Length: I— Precision: I_
oK I Cancel | Help |

11 Click OK.

You return to the List of Data Items.

List of Data ltems [ x|
Dizplay Dataitems:  ( Uged € Uruged & Al Display entity:  Mame (¢ Code
Name | Code | Entity I Data Type |U | N |:|
34 [Store Name STOR_MNAME STORE W40 |2
35 [Title ISEM TITLE_ISEM TITLE 412 il
36 |Title Motes TITLE_NOTES TITLE T=T il
37 |[Title Price TITLE_PRICE TITLE MM5,2 =l
38 |Title Publication Date  TITLE_PUEDATE TITLE D ol
33 |[Title Text TITLE_TEXT TITLE WARD =
40 [Title Type TITLE_TYPE TITLE WAZD =
41 |TitleAuthar Percent | TA_PERCENT ] rr
= [Titletwithor Order T4 _ORDER I EHEr -
New | Delete | 4] <] ] ] Sortby ' Mame & Code ( Enity
Label: I
Domain: I[None] j J
Check | Describe | Annotate | Entity | QK. I Cancel | Help |
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What you learned

40

12 Click OK.

This saves the data item definitions and returns you to the model
window.

In this section, you learned how to:

+ Refer to the statement of the business problem to decide what additional
information you need to be able to manage

Create data items to reflect these needs
Identify a data item by a name, a code, and a data type

Select a data type by attaching a data item to a domain

* & o o

Select a data type for a specific data item



Chapter 4 Defining Business Rules, Domains, and Data Items

Attach a data item to a domain

Where you are
Chapter 4 Defining Business Rules, Data Items, and Domains
Create a new business rule
Create a new domain
Create a new data item
= Attach a data item to a domain
Attach check parameters to a domain

You will attach the AMOUNT domain to all data items that store amounts of
money and the PERCENT domain to all data items that store percentages.

1 Select Dictionary>List of Data Items from the menu bar.

The List of Data Items dialog box appears.

2 Click the number of the data item Author Advance.
Press cTRL while you click the number of the data item Royalty Amount.
Press cTRL while you click the number of the data item Sale Amount.
Press cTRL while you click the number of the data item Title Price.

These data items are selected.

List of Data Items [ %]
Display Dataitemz: ¢ Used € Unused & All Display entity: ' Mame (% Code
Name | Code | Entity | Diata Type | i | N |A
3 |Store Address STOR_ADDRESS STORE Wagl v
32 |Store 1D STOR_ID 5TORE a12 [~
33 [Store Name STOR_NAME STORE W40 FI
34 |Titledwthor Order TA_ORDER TITLEAUTHOR | =
35 Titleduthar Percent TA_PERCEMT TITLEAUTHOR Sl il
Title ISEN TITLE_ISEN TITLE 812 2l
Title Notes TITLE_NOTES TITLE THT FF_I
TITLE_PRICE MID
Title Publication Date  TITLE_PUBDATE TITLE v F_|
Mew | Delete | |<| 4| ’I ”I Sort by ¢ Mame % Code ( Entity
Label: I
Diomain: I ﬂ J
Check I Desglibel Anno_tatel Eriity | ak. I Cancel I Help |

41



Attach a data item to a domain

What you learned

42

3 Select AMOUNT from the Domain dropdown listbox in the bottom part of

the dialog box.

The data items inherit the data type of the domain. MN8,2 appears in the
Data Type column. This code indicates a money data type with a length
of 8 and a precision of 2.

The data items Author Advance, Royalty Amount, Sales Amount, and
Title Price which before had different data types, now inherit a
standardized data type from the Amount domain.

List of Data Items [ %]
Dizplay Datatems: ¢ Used O Urused ™ 21 Display entity: © Mame Code
Name | Code | Entity | Diata Type | i | N |A
3 [Store Address STOR_ADDRESS STORE AR
32 |Store D STOR_ID STORE 412 F
33 [Store Name STOR_MNAME STORE WA4D ol
34 |Titletuthor Order T&_ORDER TITLEAUTHOR I =
35 Titletwthior Percent | TéA_PERCEMT TITLEAUTHOR gl il
Title ISEM TITLE_ISEN TITLE mz il
Title Motes TITLE_NOTES TITLE FF_I
TITLE_PRICE MID
Titls Publication Date | TITLE_PUBDATE TITLE FT x|
Mew | Delete | |<| 4| ’I ”I Sort by ¢ Mame % Code ( Entity
Label:
Dromain: 0N - J
Check I Desglibel Anno_tatel Eriity | ak. I Cancel I Help |

4 Click the number of the data item Discount Percent and select PERCENT
from the Domain dropdown listbox.

5 Click OK.

This saves your changes and attaches the data items to the domains.

It is good practice to attach data items to domains. By doing so, when you
modify a domain you can globally update the characteristics of the attached
data items.

In this section, you learned how to:

+ Ensure data consistency by attaching data items to domains
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Attach check parameters to a domain

Where you are
Chapter 4 Defining Business Rules, Data Items, and Domains
Create a new business rule
Create a new domain
Attach a data item to a domain
Create a new data item
® Attach check parameters to a domain

By attaching check parameters to the PERCENT domain, you will further
specify the format of percentages for all data items attached to this domain.

1  Select Dictionary>List of Domains from the menu bar.

The List of Domains dialog box appears.

2  Click the Percent domain

An arrow appears at the beginning of the line.

List of Domains
Mame | Cods | Data Type | o] | N ILI
1 [Address ADDRESS WAGD )
2 Jamount AMOUNT MME,2 M=
3 |4lphanumeric |dentifier  AM_IDENTIFIER 412 il
4 |pate DATE D 2l
5 |Numeric Identifier IDENTIFIER: gl =
£ |Long_notes LOMG_NOTES =T =
7 |Long text LONG_TEXT WA20 =
8 |Mames MAMES WAl FI=
* [Pefcent [EIFERCENT sl Fr o«
Mew | Delete | ﬂﬂﬂﬂ Sotby: ¢ Mame & Code
Label: I
Check I Dezcribe I Annotate | Uged By | ak I Cancel | Help |

3 Click the Check button.

The Check Parameters dialog box appears.

4 Type 1in the Minimum box.

This means that the minimum percentage of royalties is 1.
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Attach check parameters to a domain

5  Type 100 in the Maximum box.

This means that the maximum percentage of royalties is 100.

Check Parameters [ %]
Domain: PERCEMT [Percent]
Data type: Sl Length: Precizion:

Standard Parameters | Walidation Hulesl

T Walues — List of walues

Minimurn: W alue | Label |:|
b axirnurn: I‘I an Lo |

Default: I —

. Parameters —

Lnit: I

Farmat: I | j
" Lowercase [ Uppercase

" Cannot modify Insert | Delete | illl
Expression: © Client ™ Server

ZMINMAR and =]
ZLISTWALZ and

#RULES% J
Bules | 2000 | Preview | ok I Cancel | Help |

6 Click OK in each of the dialog boxes.

A message asks you if you want to update the data items attached to the
domain.

7  Select the Check checkbox.

This choice indicates to update check parameters for data items attached
to the domain.

Updating Data Items Using thiz Domain

@ Do you want to modify the D ata ltems of the Domain 'Percent?

Update
’7 ¥ Data type

™ Bules

Mo Cancel
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What you learned

Domain enforcement

You receive this confirmation box if you did not choose Enforce
Domains as a model option. You define domain enforcement by
selecting File-Model Options.

8 Click Yes.

This updates the data type of the data items TitleAuthor Percent and
Discount Percent.

You return to the CDM workspace.
In this section, you learned how to:

+ Standardize the data structure of data items more precisely by using
check parameters to define acceptable values

+ Globally specify acceptable values for a number of data items by
attaching check parameters to a domain

+ Define a range of acceptable values by specifying a minimum and
maximum acceptable value
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CHAPTER 5

Defining Entities

About entities

Why create an
entity

Why create an
associative entity

About entity
attributes

About entity
identifiers

An entity is an object about which you want to store information. For
example, in the tutorial model the AUTHOR entity groups information like
author name and address.

The business problem indicates which entities you need to create. For
example, to identify and store pictures of authors, you will create a
PICTURE entity that contains all information related to pictures.

To respond to another business problem, you need to keep track of the
percentage of royalties received by each author of each title.

One title may be written by many authors, and one author may have many
titles to his or her credit. This is called a many-to-many relationship.

Because each author must be unique in the Author entity, and each Title must
be unique in the Title entity, you will create an associative entity that has a
unique occurrence for each title-author combination. You will then be able to
attach a percentage to each unique case.

An entity attribute is an elementary piece of information (data item) which
you attach to an entity. For example, Last Name is an attribute of the
AUTHOR entity because it provides information about an author. You will
add a biography attribute to the AUTHOR entity.

An entity identifier is made up of one or more attributes unique to the entity,
such that each value of the identifier corresponds to one, and only one,
occurrence of the entity. For example, ISBN is the identifier of the TITLE
entity because an ISBN uniquely identifies a title. You will assign a picture
identification number as the identifier of the PICTURE entity.
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Create a new entity

Attaching business
rules to entities

48

You attach a business rule to an entity as a reminder of the conditions
attached to the entity. You will attach the business rule you created in the
preceding lesson to one of the entities.

In this chapter you will:

+ Create an entity

Create an associative entity
Define entity attributes

Designate an identifier

* & o o

Attach a business rule to an entity

How long will it take?
About 15 minutes
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Create a new entity

Where you are
Chapter 4 Defining Entities
» Create a new entity
Create an associative entity
Define entity attributes
Designate an identifier
Attach a business rule to an entity

You will create an entity that contains information related to pictures, an
entity that associates titles to authors, and two entities that differentiate title
categories: periodicals and non-periodicals.

1 Click the Entity tool in the tool palette.

2 Click in the model workspace.

An entity symbol appears at the click position.

Ent_64

At creation, an entity is named Entwheren is a number assigned to
the entityin the order of creation of objects.

3 Click the Pointer tool in the tool palette.

4 Double-click the symbol of the entity you just created.

The Entity property sheet appears.

5  Type Picture in the Name box.

This is the name of the entity.
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Create a new entity

6 Click the J button at the end of the Code box.

This sets the code equal to the name.

Entity Properties [ %]

Definition | Descriptionl Annotationl

Model: Tutarial

Mame: j
Code: [FICTURE j
Label: |

Mumber: I v Generate table

Aftributes I BRules |

ak I Cancel Aoy Help

7 Click OK.

The new entity displays the name Picture.

Picture

You created this entity by first creating its symbol, then identifying it
from a property sheet. You can also create entities from the list of
entities.

8  Select Dictionary>List of Entities.

The List of Entities dialog box displays existing entities.

9  Click New.

An arrow appears at the beginning of a blank line.
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10 Type Periodical in the Name column.
Click New.

The code is automatically set equal to the name. An arrow appears at the
beginning of a blank line.

11 Type Nonperiodical in the Name column.

The new entities appear on the list. You do not need to type a code for
this entity. By default, the code will be set equal to the name.

List of Entities
Name | Code [o]G[n]a]
3 |Publisher FUBLISHER VIV
4 |Ropalty Schedule ROYSCHED Wil
5 |5ale SaLE Vi
£ Istore STORE Vv
7 Title TITLE Wiw
B [Titleduthar TITLEAUTHOR VI
9 |Picture PICTURE Wil
10 |Perindical FERIODICAL e el
=+ |Naorperiodical VD -
Hew | Delete | ilil_blil Sortby: © Name % Code
Label: I
Mumber: I I Display ™ Generate table
Altributes I Bules I Describe | Annotate | Eirnd | QK. I Cancel |
12 Click OK.

The new entities appear in the CDM.

Periodical

|| Monperiodical

Moving entity symbols

When you create entities from the list, they will not be arranged
shown above. You do not control the insert position of the symba|s.
You can move an entity symbol by selecting it and dragging it to
new position.
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What you learned In this section, you learned how to:

+ Use the statement of the business problem to decide what entities you
need to create

+ Create an entity by inserting an entity symbol and assigning a hame and
code from its property sheet

+ Create an entity on the list of entities
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Create an associative entity

Where you are
Chapter 4 Defining Entities
Create a new entity

=® Create an associative entity
Define entity attributes
Designate an identifier
Attach a business rule to an entity

You will replace the existing relationship between AUTHOR and TITLE

with an associative entity. This associative entity will have a unique
occurrence for each title-author combination so that you can attach a royalty
percentage to each unique case.

1 Right-click the relationship that links Author and Title entities.

A relationship context menu appears.

2 Select Change to Entity from the context menu.

A new entity is inserted between Author and Title entities.

Title
Title ISBH
Title Text
Title Type
Title Price

Title Hotes
TitleAuthor Title Publication D ate

Author
Author ID
Author Last Hame
Author First Hame
Author Advance
Author Address
City
State
Fostal Code
Author Phone Number
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Define entity

54

attributes

Where you are
Chapter 4 Defining Entities
Create a new entity
Create an associative entity
® Define entity attributes
Designate an identifier
Attach a business rule to an entity

You will define entity attributes for the entities TITLEAUTHOR, PICTURE,
PERIODICALS, and NONPERIODICALS by attaching one or more data
items to each entity.

You will create entity attributes by:
¢ Adding data items to an entity

+ Creating a new entity attribute
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Add data items to an entity
You will attach existing data items to the entities TITLEAUTHOR,
PICTURE, PERIODICAL, and NONPERIODICAL.

1  Double-click the TitleAuthor entity.
The Entity property sheet appears.

Entity Properties [ x|

Diefinition | Descriptionl Annotationl

Model  Tutorial
Mame:  [Tilefuthor [~
Code  [TITLEAUTHOR
Labet |

Mumber: I V' Generate table

Altributes | Bules |

ok Cancel Apply Help
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2  Click the Attributes button.

The Attributes of the Entity dialog box appears. The list is empty
because the entity does not have any associated attributes.

Attributes of the Entity: TitleAuthor
M ame | Code | DataTwpe [1[M[D[N]<]
+ = LV
[

v | pae | st |l ioln]  #lele] 7]

Label: I
Domain: I[None] jJ [ Identifier T Mandatory I Display

Check | Desgribel Anno;atel ak I Cancel | Help |

Go directly to the list of entity attributes
You can go directly to the list of entity attributes by pressirrr
while you double-click an entity.

3 Click the Add button.

The Selection of Data Items dialog box appears. It displays the list of
data items.

4 Click the Unused radio button at the top of the dialog box.

This displays only the data items that are not attached to an entity.
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5  Click the Code radio button at the bottom of the dialog box.

This sorts the list of data items by code.

Selection of Data ltems [ %]

Display Dataitems: ¢ Used Display entity: © Mame Code
Name | Code | Enitity [o]<]
= [Bock collection MOMP_COLLECTIOM r
2 Feriodical Format FER_FORMAT
3 Penodical Pub Frequency PER_FREGQUENCY -
4 |Picture ID Pl¥_ID Il
5 Ficture Flx_PICTURE r
B Titledwithor Order TA_ORDER r
7 TitleAwthor Percent TA_PERCEMT r
™ Duplicate ﬂil_bl M| Sotby: © Name @ Code ¢ Entity
caeal

6 Click the number at the beginning of the TitleAuthor Order line.
Press cTRL while you click the number at the beginning of the TitleAuthor
Percent line.

The two data items are selected.

Selection of Data ltems [ %]

Display Dataitems: € Used & Unused Al Display entity: ' Mame (% Code
Name | Code | Enitity [o]<]

|1 |Book collection MOMP_COLLECTIOM r

|2 |Periodical Format FER_FORMAT r

|3 |Periodical Pub Frequency PER_FREGQUENCY -

4 |Picture 1D Fix_ID I

5 Ficture Flx_PICTURE r

uthor Order _D

T i —" T4 PERCENT | |
[

™ Duplicate ﬂil_blil Sorthy: ¢ Mame * Code € Ertity

Cancel |
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Define entity attributes

7  Click OK.
The data items appear in the list of attributes for the TitleAuthor entity.
Name | Code | DataTwpe [1[M[D][N]<]
1 |Titleduthor Order T4_ORDER I [T
+ Fiieduthor Percent iT4_PERCEMT gl C W
|| =l
Insert | Delete | Add.. | W] F a4+ F] 2]
Label: I
D'omain: IPEHEENT jJ [ Identifier [~ Mandatory W Digplay
Check I Dezcribe I Anno_tatel ak. I Cancel I Help |

8 Click OK in each of the dialog boxes.

In the CDM workspace, the TITLEAUTHOR entity displays its
attributes.

TitleAuthor

TitleAuthaor Order
TitleAuthor Percent

9 Repeat steps 1-7 for the following entities:

For the entity Select the data items
PICTURE Picture ID

Picture
PERIODICAL Periodical Format

Periodical Pub Frequency
NONPERIODICAL | Book Collection

The CDM displays these entities with their attributes.

Picture MNonperiodical Periodical
Picture 1D Book collection Periodical Format
Picture Periodical Pub Frequency
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Chapter 5 Defining Entities

Create a new entity attribute

You will create a new Biography attribute for the text of the author's
biography.

1  Double-click the AUTHOR entity symbol.
The Entity property sheet appears.

Entity Properties [ x|
Diefinition | Descriptionl Annotationl

tdodel: Tutarial

Mame: |
Code  [4UTHOR

NN

Label: I

Mumber: I V' Generate table
Altributes I Bules |

ok | Cancel Loy Help

2 Click the Attributes button.
The Attributes of the Entity dialog box displays the attributes belonging
to the Author entity.

3 Select the Author Advance attribute.
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Define entity attributes

4  Click the Insert button.

A blank line is inserted above the Author Advance line.

Attributes of the Entity: Author [ %]
Name | Code | DataTwpe [I[M[D]N]<
T lauthor ID AL_ID A12 VT |
2 |&uthor Last Name Al_LNAME ] ¥
3 |awthor First Name AU_FNAME ] ¥
- CCVI
5 m CE CICIFIC]
3 uthor Address A_ADDRESS VT
7 |ci CTy MAZD VT
8 [State STATE AZ P
8 |PostalCode POSTALCODE AR CCFE =
Insert | Delete | Add.. | W] F a7 2]
Label: I
D'omain: I[None] j J [ Identifier [~ Mandatory W Digplay
Check I Dezcribe I Annotate | ak. | Cancel I Help |

5  Type Author Biography in the Name column.

This is the name of the attribute.
6 Type AU_BIOGRAPH in the Code column.
7  Select LONG_NOTES from the Domain dropdown listbox in the bottom

part of the dialog box.
The text data type (TXT) appears in the Data Type column.

Attributes of the Entity: Author [ %]
Name | Code | DataTwpe [I[M[D]N]<
1 [Author D AU_ID M|
2 |&uthor Last Name ALU_LMAME (i
3 |awthor First Name AU_FNAME C vVl
= |&uthor Biography Al_BIDGRAPH TV
5 |owuthor Advance AU_ADVAMCE CCWT
B |author Address AU_ADDRESS W
7 ;i CITY W
B |State STATE C W
8 |PostalCode POSTALCODE CCFE =
Insert | Delete | Add.. | W] F a7 2]
Label: I
D'omain: ILDNG_NDTES j J ™ Identifier ™ Mandatory W Dizplay
Check I Dezcribe I Annotate | ak. I Cancel I Help |
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Chapter 5 Defining Entities

What you learned

8

In this section, you learned how to:

Click OK in each of the dialog boxes.

The Author entity displays its new attribute.

Author

Authaor 1D

Author Last Mame
Authar First Mame
Author Biography
Author Advance
Author Address

City

State

FPostal Code

Author Phone Mumber

+ Add existing data items to an entity to create entity attributes

+ Create a new entity attribute

*

Identify an entity attribute by a name, a code, and a data type
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Designate an identifier

Designate an identifier
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Where you are
Chapter 4 Defining Entities
Create a new entity
Create an associative entity
Define entity attributes

® Designate an identifier
Attach a business rule to an entity

An identifier is an entity attribute that uniquely identifies each occurrence of
the entity.

You will designate Picture ID as the identifier of the PICTURE entity.

1 Double-click the PICTURE entity symbol.
The Entity property sheet appears.

Entity Properties [ x|

Diefinition | Descriptionl Annotationl

odel: Tutorial

Mame: Ficture] j
Code:  [PICTURE [~
Label: I

Mumber: I V' Generate table

Altributes | Bules |

ok I Cancel Loy Help




Chapter 5 Defining Entities

2 Click the Attributes button.
The Attributes of the Entity dialog box appears.

Name | Code | DataTwpe [1[M[D][N]<]
> [EIPE<_ID ] [TV
2 [Ficture Plx_FICTURE PIC CrME
[~
Insert | Delete | Add.. | ] F 2|2 F] ]
Label: I
D'omain: IIDENTIFIEH j J ™ Identifier ™ Mandatory W Dizplay
Check I Desglibel Anno_tatel ak. I Cancel I Help |

3 Click the Picture ID attribute.

An arrow appears at the beginning of the line.
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Designate an identifier

4 Select the Identifier checkbox in the bottom part of the dialog box.

In the Picture ID line, checks in the | column and the M column indicate
that this attribute is an identifier and a mandatory attribute, respectively.

Checkbox columns on the list of attributes

The list of attributes has four checkbox columns: | for identifier, M
for mandatory, D for display, and N for notes. The N column contgins
a check if the attribute is annotated.

Name | Code | DataTwpe [1[M[D][N]<]
+ FicirelD PI%_ID H] icica
2 [Ficture Plx_FICTURE PIC CrME
|| [~
Insert | Delete | Add.. | WA F x| F] ]
Label: I
D'omain: IIDENTIFIEH j J W Identifier W Mandatory W Dizplay
Check I Desglibel Anno_tatel ak. I Cancel I Help |

5  Click the Picture attribute.

An arrow appears at the beginning of the line.
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Chapter 5 Defining Entities

6  Select the Mandatory checkbox in the bottom part of the dialog box.

A check appears in the M column of the Picture attribute. This means the
attribute is mandatory. In other words, each occurrence of the Picture
entity must include a picture.

Name | Code | DataTwpe [1[M[D][N]<]
1 Picture 1D Plx_ID 5l v v v
R B PIETURE AIE rerFr
|| [~
Insert | Delete | Add.. | W] w2+ F] 2]
Label: I
D'omain: I[None] j J [ Identifier ¥ Mandatory W Digplay
Check I Dezcribe I Anno_tatel ak. I Cancel I Help |

7 Click OK in each of the dialog boxes.

The Picture ID attribute is underlined in the PICTURE entity symbol to
indicate that it is the identifier.

Picture

Picture 1D
Picture

What you learned In this section, you learned how to:
+ Designate an entity attribute as an identifier

+ Make an entity attribute mandatory
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Attach a business rule to an entity

Attach a business rule to an entity
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Where you are
Chapter 4 Defining Entities
Create a new entity
Create an associative entity
Define entity attributes
Designate an identifier

® Attach a business rule to an entity

You will attach the Author Percent business rule to the TITLEAUTHOR
entity to remind you of the role of this entity in the calculation of author
royalties.

1  Click the Properties tool in the tool palette.

Click the TitleAuthor entity symbol.
The Entity property sheet appears.
Entity Properties [ x|

Diefinition | Descriptionl Annotationl

tdodel: Tutarial

Mame: IT Heduthar j
Code: |TITLEAUTHDF|
Label: I

Mumber: I V' Generate table

Altributes | Bules |

ok Cancel Apply Help




Chapter 5 Defining Entities

2  Click the Rules button.

The Business Rule of the Entity dialog box lists the business rules
associated with the entity. This list is empty.

Business Rule of the Entity: TitleAuthor
Mo  Mame Code Type Expr Mate

Add. | Eemovel Operator: O

% Description

« and

| Client expression. € Server expression §) Sonotation

=

[
[ efine | Zoom | List | ak I Cancel | Help |

Click the Add button.

The List of Business Rules appears. This lists all the available business
rules.

Click Author Percent.

This selects the Author Percent business rule.

List of Busines: Rules

Mo Mame Code

1 Advance ADVANCE

2 Author Percent ALTHOH FPERCERT
3 Author Sales AUTHOR_SALES

4 Royalties ROYALTIES

5 Fopaly Ranges ROYVALTY_RAMGES
E Salesin Stores

SALES_IN_STORES

Sort by € Mame & Code

Cancel |
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Attach a business rule to an entity

5 Click OK.

You return to the Business Rule of the Entity dialog box. Author Percent
appears in the list.

Business Rule of the Entity: TitleAuthor
Mo Mame Code Type Expr MNate

1 Author Percent Y alidation

AUTHOR _PERCENT

Remove |

@& Descipion  © Client expression € Server expression ¢ Annotation

The percentage of royalties paid to all authors of a book adds wp to 100 of the ;I
total ropalties.

|

Define | Zoom | List | ak | Cancel | Help |

6 Click OK in each of the dialog boxes.

The business rule is attached to the entity. You return to the model
window.

What you learned In this section, you learned how to:

+ Attach a business rule to a particular entity in the CDM

+ Use a business rule as a reminder of the role of an object in solving a
business problem
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CHAPTER 6

Defining Relationships

About relationships

About cardinality

About mandatory
relationships

About dependent
relationships

A relationship is a named association between entities. It expresses the fact
that two entities are somehow related. For example, in the tutorial model, a
relationship links the entities PUBLISHER and TITLE because publishers
publish books. An entity can have a relationship with itself, called a reflexive
relationship.

Cardinality indicates the maximum number of instances (one or many) of
one entity in relation to another. To determine the cardinality of a
relationship, ask the following question about each entity in the relationship,
"Can more than one occurrence of this entity exist for one occurrence of the
other entity?"

For example, in the direction author-to-picture, the cardinalityainy

because one author can be shown in several pictures. In the direction picture-
to-author, the cardinality snebecause a picture can only show one author.
This type of relationship is called a one-to-many relationship.

You can define a relationship as mandatory from the point of view of one or
both of its entities. To determine if a relationship is mandatory, ask the
following question about each entity in the relationship, "Does an occurrence
of this entity require an occurrence of the other entity?"

For example, the relationship for DISCOUNT to STORE is mandatory
because all discounts must be associated with a specific store. On the other
hand, the relationship from AUTHOR to PICTURE will be optional because
an author may not have any pictures on file.

In a dependent relationship one entity depends on another to uniquely
identify it. For example, there are dependent relationships from
TITLEAUTHOR to TITLE and to AUTHOR because a unique occurrence of
TITLEAUTHOR is formed by the combination of one author and one title.
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Create a relationship

What you will do In this chapter you will:
+ Create a one-to-many relationship

+ Define roles in an optional relationship

How long will it take?
About 10 minutes.
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Chapter 6 Defining Relationships

Create a relationship

Where you are
Chapter 5 Defining Relationships
» Create a relationship
Define roles in an optional relationship

You will create a relationship between AUTHOR and PICTURE entities.
1 Click the Pointer tool in the tool palette.

2 Drag the Picture entity symbol under the AUTHOR entity symbol.

Author
Author 1D
Author Last Mame
Author First Mame
Author Biography
Author Advance
Author Address
City
State
FPostal Code
Author Phone Mumber

Picture

Picture I
Picture

[Es| 3  Click the Relationship tool in the tool palette.
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Create a relationship

4 Click and drag a relationship line from AUTHOR to PICTURE.

Author
Author 1D
Author Last Mame
Author First Mame
Author Biography
Author Advance
Author Address
City
State
FPostal Code
Author Phone Mumber

Picture

Picture I
Picture

The contact points of the relationship indicate that the cardinality of the
relationship from AUTHOR to PICTURE is one-to-many, as follows:

+ A single contact point on AUTHOR indicates that there is only one
author for each picture

+ Three contact points (a crow's foot) on PICTURE indicates that the
same author can have more than one picture

The circles before both termination points indicate that both sides of the
relationship are optional.

Relationship properties
Relationships that you create using the relationship tool are one-{o-
many and optional. You can change these and other properties fijom
the relationship property sheet.

What you learned In this section, you learned how to:

+ Translate the links between objects in the information system into
relationships between entities

+ Ask appropriate questions to help you decide the cardinality of a
relationship
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Define roles in an optional relationship

Where you are
Chapter 5 Defining Relationships
Create a relationship

= Define roles in an optional relationship

You will define an optional relationship between AUTHOR to PICTURE. An
author does not have to have a picture. A picture does not have to be of an
author.

1  Click the Pointer tool in the tool palette.

2 Double-click the relationship line between AUTHOR and PICTURE.
The Relationship property sheet appears:

Relationship Properties [ %]

Definition | Descriptionl Annotationl

Author Picture

Authar i Picture I
Name: [Relation_125 _=| Code [RELATION_125 [-
Label: I
— LCardinality

© OnetoOne & One to Many  Many to One © Many to Many

— “Author'' to "Picture”

[~ Mandatory [ Dependent T Dominant Hin: ID Max: In
Rals: |

— "Picture" ko “Authar!

[ Mandatory [ Dependent ™ Dominant tin: ID b aw: |1
Rale: I

FRules | WV Generate
ok I Cancel | Loy | Help

3 Type Author Picture in the Name box.

This is the name of the relationship.
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Define roles in an optional relationship

74

Click the J button at the end of the Code box.

This sets the code equal to the name.

Type is shown in in the Role box in the "Author" to "Picture" groupbox.

This label indicates that an auttisishown ima picture.

Type shows in the Role box in the "Picture" to "Author" groupbox.

This label indicates that a pictuishowsan author.

Relationship Properties [ %]

Definition | Descriptionl Annotationl

Author Ficture

Authaor I Picture I
Mame: [Author Ficture _=| Gode [AUTHOR_PICTURE [-
Label: I
— LCardinality

© OnetoOne & One to Many  Many to One © Many to Many

— “Author'' to "Picture”

[~ Mandatory [ Dependent T Dominant Hin: ID Max: In

Rals: |is shawn in

— "Picture" ko “Authar!

[ Mandatory [ Dependent ™ Dominant tin: ID b aw: |1

Rale: Ishows

FRules | WV Generate
ok I Cancel | Apply | Help
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7 Click OK.

The relationship appears in the model.

Author
Authaor 1D
Author Last Mame
Author First Mame
Author Biography
Author Advance
Author Address
City
State
FPostal Code
Author Phone Mumber

&

is shown in
I

shows

Picture

Picture 1D
Picture

Display relationship roles
You can display roles by selecting Pi®isplay Preferences and
selecting the Role checkbox in the Relationship groupbox.
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CHAPTER 7
Creating a Submodel

Submodels help you manage large models. The global model contains all
objects. The submodel contains a selection of objects from the global model.

You will create a submodel containing the entities TITLE, PERIODICAL,
and NONPERIODICAL.

In this chapter you will:
¢ Create a submodel

+ Add objects to the submodel

How long will it take?
About 5 minutes.
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Create a submodel

Create a submodel

Where you are

Chapter 7 Creating a submodel
» Create a submodel

Add objects to the submodel

You will start building the submodel with the TITLE entity.

1  Click the TITLE entity symbol to select it.

2 Select Dictionary> Submodel>New from the menu bar.

A new model window appears containing the TITLE entity.

Create an empty submodel
You can create an empty submodel by selecting Submaddial
without selecting an object.
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Chapter 7 Creating a Submodel

Select Dictionary>Model Properties from the menu bar.

The submodel property sheet appears. It has the same project name and
code as the global model.

Model Properties [ %]

Definition | Descriptionl Annotationl

Project name: |Publications j
Project code: IF'UBLID’-\TIDNS j
Mame: IMode|_4 j
Code: |MODEL_4 j
Label: I

Authar: |user Wersion: l—

Language: I English [United States) j

File: C:\Pw/ RS WPDEAE wampleshtutorial cdm

Created: 3727797 2:20 PM Modified: 372797 2:20 PM

ak I Cancel | Aoy Help

Type Title Categories in the Name box.

You overwrite the name Modei name assigned by default.
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Create a submodel

5 Click the J button at the end of the Code box.

Definition | Descriptionl Annotationl

Project name: |Publications

Project code: IF'UBLID’-\TIDNS

Lo Lo (o e

Mame: ITitIe Cateqganies
Code: |TITLE_E.|'-‘«TEGDFHES
Label: I

Authar: |user Wersion: l—
Language: I English [United States) j

File: C:\Pw/ RS WPDEAE wampleshtutorial cdm

Created:  3/27/97 220 PM Modified: 3/27/97 2:20 P

Cancel Apply Help

6 Click OK.
You return to the submodel CDM workspace.

B FesmUenges Datafchiec - | SubL0M | il Calogemr

Tilim Fublieakbus 3 ate
-
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What you learned In this section, you learned how to:
+ Create a submodel starting with one of the objects in the global model

+ |dentify a submodel by a name and a code
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Add objects to the submodel

Add objects to the submodel

Where you are
Chapter 7 Creating a submodel
Create a submodel

® Add objects to the submodel

You will add the PERIODICAL and NONPERIODICAL entities to the
submodel.

1  Select Dictionary> Submodel > Add/Remove Objects.
The Select Objects dialog box appears.

Select Objects

Awailable objects Selected objects

[eny <] T ——
I

BLTHOR
DISCOUNT
NOWPERIODICAL
PERIODICAL
PICTURE
PUBLISHER
ROvSCHED
SALE

STORE
TITLEAUTHOR

"~ [

Ledd Add all >» | Bemaove << Remove all << |

Cancel |

Entity "Author'*

The dialog box displays all the entities in the global model. The TITLE

entity appears in the list of selected objects because it is already in the
submodel.

2 Select the NONPERIODICAL entity.

82



Chapter 7 Creating a Submodel

3 Press the sHIFT key while you select the PERIODICAL entity.

Select Objects [ %]
Awailable objects Selected objects
[Entiy =] AT |

[

Add s> Add all >» | Bemaove << Remove all << |

Entity "'Periodical”* Cancel |

4 Click the Add button.

PERIODICAL and NONPERIODICAL appear in the Selected objects
list.

Select Objects [ %]

Awailable objects Selected objects

E ntit - ity HOMPERIODICA)
[eniy E ntity FERIODICAL
E ritity TITLE

DISCOUNT
PICTURE
PUBLISHER
ROvSCHED
SALE

STORE
TITLEALUTHOR

[

=
Add s> I Add all >» | Bemaove << Remove all << |

Entity “Authar oK | Cancel |
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Add objects to the submodel

5 Click OK.

Three entities appear in the submodel window.

6 Drag and drop the PERIODICAL and NONPERIODICAL entity symbols to
position them under TITLE.

Title
Title ISBMN
Title Text
Title Type
Title Price
Title Motes
Title Publication Date

Manperiodical Periodical
Book collection Periodical Format
Periodical Pub Frequency

What you learned In this section, you learned how to:
+ Select the objects you want to include in a submodel

+ Add the objects to the submodel
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CHAPTER 8

Defining Inheritance

About parent
entities

About child entities

Making children
mutually exclusive

What you will do

Inheritance allows you to define an entity as a special case of a more general
entity. For example, you will define periodicals and non-periodicals as
special cases of titles.

The general entity is known as tharent (or supertype) entity, and contains
all of the common characteristics. In this tutorial, you will use TITLE as the
parent entity.

The special case entity is known as¢héd (or subtype) entity, and contains
all of the particular characteristics. In this tutorial, you will create two child
entities, PERIODICAL and NONPERIODICAL, because they are special
cases of titles with specific attributes.

You can make an inheritance mutually exclusive. When an inheritance is
mutually exclusive it means that there cannot be an occurrence of both child
entities at the same time.

For example, a title can be a periodical or a non-periodical. Because it cannot
be both, it is a mutually exclusive inheritance.

In this chapter you will:
+ Create an inheritance link
+ Define inheritance properties

+ Add the submodel graphics to the global model

How long will it take?
About 10 minutes.
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Create an inheritance link

Create an inheritance link

86

Where you are
Chapter 7 Defining Inheritance
® Create an inheritance link
Define inheritance properties
Add the submodel graphics to the global model

You will define an inheritance from the TITLE entity to the PERIODICAL
and NONPERIODICAL entities.

1

Select the Inheritance tool in the tool palette.

Drag an inheritance link from TITLE to NONPERIODICAL.

An inheritance link appears between these entities. The link has a
semicircle in the middle, and an arrow that points to TITLE, which is the
parent entity. NONPERIODICAL is the child entity.

Title
Title ISBMN
Title Text
Title Type
Title Price
Title Motes
Title Publication Date

Manperiodical
Book collection




Chapter 8 Defining Inheritance

3 Click the semicircle and drag an inheritance link to the PERIODICAL entity.

The inheritance symbol changes accordingly.

Title
Title ISBMN
Title Text
Title Type
Title Price
Title Motes
Title Publication Date

Monperiodical Periodical
Book collection Periodical Format
Periodical Pub Freguency

Position inheritance symbol

To arrange the position of the inheritance symbol, select the
semicircle then select ArrangéispositiorArrange Symbols. The
inheritance symbol moves to the center of gravity of the symbols
connects.

What you learned In this section, you learned how to:
+ |dentify entities which are special cases of other entities

¢ Create an inheritance link between entities
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Define inheritance properties

Define inheritance properties

88

Where you are
Chapter 7 Defining Inheritance
Create an inheritance link
= Define inheritance properties
Add the submodel graphics to the global model

You will assign a name to the inheritance, make it mutually exclusive, and
define its generation mode.

1 Click the Pointer tool in the tool palette.

2  Double-click the semicircle in the middle of the inheritance link.

The Inheritance property sheet appears.

3 Type Title inherit in the Name box.

This is the name of the inheritance.

4  Click the j button at the end of the Code box.

This sets the code equal to the name.

5  Select the Mutually exclusive checkbox.

This indicates that the inheritance is mutually exclusive because a title is

either a periodical or a non-periodical, never both.

6 Clear the Generate children checkbox in the Generation Mode groupbox.

The choices you make in the Generation Mode groupbox indicate how
the inheritance will be generated in the Physical Data Model (PDM).
Selecting only Generate Parent means only one table will be generated
for all titles. In this case, you will need a specifying attribute to
differentiate occurences of each child.



Chapter 8 Defining Inheritance

Type Periodical in the Name box in the Generation Mode groupbox.

Periodical is the name of the specifying attribute. This specifying
attribute will generate a column named Periodical in the TITLE table
that will result from generation. This column will indicate whether a title
is a periodical or not.

Click the J button at the end of the Code box in the Generation Mode
groupbox.

Type BL in the Type box in the Generation Mode groupbox.

You define a Boolean (BL) data type for the specifying attribute because
there are only two possible choices: periodical or not.

Inheritance Properties [ %]
Definition | Descriptionl Annotationl
Mame: |Title ifherit j
Code: |TITLE_INHEF|IT j
Label: I
Supertype entity [parent): T Gemeration made
Title | ¥ Generate parent
” N ™ Generate children
Sub-type entities (children): & Inherital 1 Inherit identifier
o Perogial Specifying attribute:
MHarne: IF'eriodicaI j
Code: [PERIODICAL [~
Type: IBL ?| Length:
¥ Mutually excluzsive J I_
Child | Bules |
ak I Cancel Apply Help
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10 Click OK.

A cross appears in the semicircle to indicate that the inheritance is
mutually exclusive.

Title
Title ISBMN
Title Text
Title Type
Title Price
Title Motes
Title Publication Date

Monperiodical Periodical
Book collection Periodical Format
Periodical Pub Freguency

What you learned In this section, you learned how to:
+ |dentify an inheritance by a name

+ Express the fact that only one child entity can exist at a time by making
the inheritance mutually exclusive

+ Select a generation mode to indicate what tables to generate for the
inheritance

+ Define a specifying attribute to identify subtypes in the same table
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Chapter 8 Defining Inheritance

Close the submodel and update graphics in the

global model

Where you are
Chapter 7 Defining Inheritance
Create an inheritance link
Define inheritance properties
®» Close the submodel and update graphics in the global model

When you create an object in a submodel, the definition of the object is
automatically included in the global model. On the other hand, the graphic

symbol of the object does not automatically appear in the global model. You

have to explicitly request to update the global model graphics.

You created an inheritance in the submodel Title Categories. In order to
display the inheritance link in the model, you will update graphics in the
global model.

If you created the inheritance in the global model
If you created the inheritance in the global model window, you can sk|p
the procedure below. You create an inheritance in exactly the same
manner from the global model window as you do from the submodel
window.

1 From the submodel window, select File »Close.

This closes the submodel and returns you to the window containing the

global model.

2 Select Dictionary> Submodel>Update Graphics from the menu bar in the
global model window.

A Confirmation message box appears.

PowerDesigner - Confirmation

Do you want to generate default symbals for all objects without syrmbols? Select "ves" to
generate symbols for all such objects. Select "'Ma” to only generate spmbals for links.

Mo Cancel
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Close the submodel and update graphics in the global model

3 Click Yes.

The inheritance link appears in the global model.

4 Drag and drop the inheritance link and entity symbols to position them
under the TITLE entity symbol.

Title
Title ISBMN
Title Text
Title Type
Title Price
Title Motes
Title Publication Date

Monperiodical Periodical
Book collection Periodical Format
Periodical Pub Freguency

What you learned In this section, you learned how to:

+ Update the graphic display so that the global model displays objects
created in a submodel
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CHAPTER 9

Organizing the Display

When you finish creating the CDM, you can organize the model using the
graphic display options.

In this chapter you will:

¢ Add atitle box

Change the color of the title box
Change the color of the window
Arrange the symbols

Straighten relationship lines

Center the model on the page

* & & ¢ o o

Print the model

How long will it take?
About 15 minutes.
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Add a title box

Add a title box

What you learned

94

Where you are

Chapter 8 Organizing the Display
®» Add a title box

Change the color of the title box

Change the color of the window

Arrange the symbols

Straighten relationship lines

Center the model on the page

Print the model

You will add a title box to the model. The title box contains the essential
information about the model.

1  Select Edit>Add Title from the menu bar.

A title box appears in the middle of the model.

Conceptual Data Model

Project : Publications
hlodel : Tuterial
Author :user [Wersion: 1.0 |11/25/96

2 Drag the title box to the top of the model.

3 Select Format »Shadow.

A shadow appears behind the title box. You can apply shadow to any
symbol in the model.

Conceptual Data bodel

Froject : Publications
hfodel : Tutarial
Author : user |\u‘ersion: 1.0 |11."25.'96

In this section, you learned how to:
+ Display the model properties in a title box

+ Apply shadow to a title box



Chapter 9 Organizing the Display

Change the color of the title box

Where you are
Chapter 8 Organizing the Display
Add a title box

= Change the color of the title box
Change the color of the window
Arrange the symbols
Straighten relationship lines
Center the model on the page
Print the model

1  Select the title box.

2 Select Format>Background Color.

3 Select a color in the palette.

4 Click OK.

The title box background changes to the selected color.

Conceptual Data Model

Project : Publications
fdodel : Tutorial
Author © user |Version: 1.0 |11.Q§!QB

Set default colors

You can set default colors for symbols in the model, by selecting
File>Display Preferences and indicating color options on the
Symbols page.
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Change the color of the window

Change the color of the window

Where you are
Chapter 8 Organizing the Display
Add a title box
Change the color of the title box

® Change the color of the window
Arrange the symbols
Straighten relationship lines
Center the model on the page
Print the model

By changing the window color, you can change the background color of the
model.

1  Select Window>Window Color.

2 Select a color in the palette.

3 Click OK.

The model background changes to the selected color.

Window color applies to all models
Window color is saved in the Windows registry or PD6.INI file. After
you choose a color, it applies to all models that you open.

96



Chapter 9 Organizing the Display

Arrange the symbols

Where you are
Chapter 8 Organizing the Display
Add a title box
Change the color of the title box
Change the color of the window

® Arrange the symbols
Straighten relationship lines
Center the model on the page
Print the model

You will align the entity symbols on the left of the model.

1 Using the Pointer tool, draw a rectangle encompassing the TITLEAUTHOR,
AUTHOR and PICTURE entity symbols.

Selecting several symbols at once
You can also select more than one symbol at a time by pressing the
SHIFT key whil you click each symbol in turn.

Z| 2 Click the center align tool in the toolbar.

This aligns the selected symbols along a central vertical axis.

TitleAuthor
TitleAuthor Order
TitleAuthor Percent

i

Author
Author 1D
Author Last Hame
Author First Hame
Author Biography
Author Advance
Author Address
City
State
Fostal Code
Author Phone Humber

= hawn in

haws

i

Picture

Picture ID
Ficture
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Arrange the symbols
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Use the Alignment tools to align the other symbols.

You can align your model as follows:

Conceptual ata hodel

Froject : Publications

Model : Tuterial

Titlefuthor

TitleAuthor Order
TitleAuthor Percent

Author

Awuthor ID

Author Last Hame
Author First Hame
Author Biography
Author Advance
Author Address

City

State

Faostal Code

Author Phone Number

Author © user [Wersion 1.0 |Q!8!Q?

Rovalty Schedule

Rovalty Low Range
Rovalty High Range
Rovalty Amount

= zhawnin
|

Thaws

Ficture

Ficture 1D
Picture

applies o
Title L)
Title 1SBH L Publisher
Title Text Fublisher ID
EI>O|— Title T!{Pe Ebomrnﬂ“""’_k Fublisher Name
Title Price City
Title Hotes State
Title Publication Date \\"‘\
i al
2 Sale
\O'S Sale Invoice D
Sale Date
Feriodical — Sale Amount
__ ernodica Monperiodical Sale Terms
Feriodical Format Book collaction Sale Quantity
Periodical Pub Frequency
\atzz phasa in
Discount Store
Dizcount I Store D
Discount Percent i hgiw,m_mm_P- Store Hame
Dizcount Type City
Loww Quantity State
High Quantity FPostal Code

Store Address




Chapter 9 Organizing the Display

Straighten relationship lines

Where you are
Chapter 8 Organizing the Display
Add a title box
Change the color of the title box
Change the color of the window
Arrange the symbols

=® Straighten relationship lines
Center the model on the page
Print the model

You will straighten the relationship line between the DISCOUNTS and
STORES entities. If this line is already straight, use another relationship line.

1 Click the relationship line.

Discount Shore
Discount 1D 15 given to. 4 otore O
Discount Petcent [0 recehies | Store Name
Discount Type Sgte
Low Quantity Postal Code
High Gluantity Store Address

2 Select Arrange> Disposition>Horizontal.

The relationship line becomes horizontal.

i Staore
Discount

i Stare D
Discount ID

i [ Stare Mame
Discount Percent is given tozs Cit
Discount Type ¥

i State
Low Cluantity
High Quantity Paostal Code
Stare Address

Select all relationships at once
You can select all the relationships at once by double-clicking the
Relationship tool in the tool palette.
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Center the model on the page

Center the model on the page

Where you are
Chapter 8 Organizing the Display
Add a title box
Change the color of the title box
Change the color of the window
Arrange the symbols
Straighten relationship lines

=® Center the model on the page
Print the model

@ 1 Click the Zoom to Current Page tool in the toolbar.

This displays the entire current page in the work area. Your model may
be spread over two pages, or may be off-center.

PowerDesigner DataArchitect - [ CDM Tutorial ] [_ O] x]
File Edit Dictionary Arange Format ¥iew Window Help

=[] |
Dl|RE] %|m=mE 2dv el folE S| S| w0 x| Foo 2
=
[




Chapter 9

Organizing the Display

] 2

Click the Grabber tool in the tool palette.

Click the model.

This selects the whole model.

Drag the model to the center of the page.
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Print the model

Print the model

Where you are
Chapter 8 Organizing the Display
Add a title box
Change the color of the title box
Change the color of the window
Arrange the symbols
Straighten relationship lines
Center the model on the page

® Print the model

You can now print the finished model.

1 Select File>Print Graphics.

The Print Graphics dialog box appears. One page is selected for printing.

Print Graphics [ x|
Humber of copies: I
mPages |
o« Al  Selected
~ Options

¥ Frame [~ Carner
& Black & white

& Color
— Prnter parameters
Frinter: Cachou on Y\Cachou'post
R esalution: E00 Dpi Paper: 210 % 257 mm, Portrait
Mumber of pages: 1 el |
2 Click OK.

Select pages to print

When a model is spread over several pages you can select and
deselect pages for printing by clicking them. Selected pages display a
turned down corner.
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CHAPTER 10

Generating the PDM from the CDM

In this lesson you will generate a Physical Data Model (PDM) from a
Conceptual Data Model (CDM).

What happens You generate a PDM for a particular Database Management System
when you generate (DBMS). Before you generate the PDM, you must select the DBMS referred
a PDM to as the target database. DataArchitect translates the data types specified in

the CDM into the physical data types which the target database supports.

The correspondence between conceptual and physical data types is defined in
a DEF file. There is a DEF file for each type of target database.

When you generate a PDM, DataArchitect also translates the following
conceptual objects into the following physical objects:

Conceptual object  Physical object

Entity Table

Entity attribute Table column

Identifier Primary key

Relationship Reference and foreign key
What you will do In this lesson you will:

¢ Generate the PDM
¢ Save and close the PDM
¢ Save CDM and exit DataArchitect

How long will it take?
About 5 minutes.
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Generate the PDM

Generate the PDM

Where you are

Chapter 10 Generating the PDM from the CDM
®» Generate the PDM

Save and close the PDM

Exit DataArchitect

1 Select Dictionary>Generate Physical Model.

A message box asks you if you want to save changes to
TUTORIAL.CDM.

PowerDesigner - Confirmation E

@ Do you want ta save thiz model before the generation?

] | Cancel I

If you have installed Metaworks

If you have installed Powerdesigner Metaworks you receive the
Generate a Physical Data Model message box instead of the
confirmation box shown above. In this case, select the Save Model
Before Generation radio button.

2  Click the Yes button

The Generate a Physical Data Model dialog box appears.

3 Select Sybase SQL Anywhere 5.5 from the Database Name dropdown
listbox.

To follow the exercises in the PDM tutorial, you must select Sybase SQL
Anywhere 5.5. However, you do not have to install the DBMS itself.

The dialog box proposes TUTORIAL.PDM as the default name for the
PDM file. It is the same as the CDM file name but with the extension
PDM.

4  Clear the Preserve Modifications checkbox.

With this option, you will replace an existing PDM with the same name.
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Chapter 10 Generating the PDM from the CDM

7

Clear the Generate Submodels checkbox.

This means that the submodel that contains the inheritance of TITLE,
PERIODICAL and NONPERIODICAL will not generate a PDM
submodel.

Select the Display Warnings checkbox.

This means that warning messages will be displayed in the Messages
window when you generate the PDM.

Generating Physical Data Model
Databaze name: IS_l,lbase SOL Angwhere 5.5 j
PO file name: IC: WP SSPD BAE Rampleshtutarnial PDM

Generation | Preservation |

— Options  Index

¥ Preserve modifications PH index name: IZTABLEO/LPK
[V Generate submodels FE index name: |°/°HEFH°/°_FK
o i

. Index threshold: I

™ Generate annotation

¥ Generate gynonym

V' Check madel ~ Referance

IV Display warnings Update rule: I FRiestrict - I

 Table | | Deleterule IHestrict 'I
Table prefis: I

ok I Eancell Help |

Click OK.

DataArchitect checks the model before it generates the PDM. The
Messages window displays the result of the check.

| |_gw | (o ] oo

Diiks e "Fesiad Code™ FOETALOODE] =]
Daacdars) [ riie.
Crachang Fialsheerhpe

Dhumibirn] Il e

Hend U snajs] Jwemngi|
Thies Wil | DODNSIE, i SO0 vard® b
Limnarairgg Fhpocs U sds Mecks] ] ulonad™
Frsvirs ety ittt
=
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Generate the PDM

Warning messages indicate that the CDM reuses certain data items for
more than one entity. These warnings are informational and do not
prevent DataArchitect from generating the PDM.

8 Click OK to close the message window.

The PDM appears in the model window.

o Prssma [l eigree Dostatschetact - | PDM Tulona |

Crowded PDM

If your PDM is difficult to read because tables display too much
information, you can reduce the amount of information displayed by
selecting File-Display Preferences and clearing checkboxes.

Three inheritance entities resulted in one table
In the CDM, you defined the inheritance Title Inherit to generate the
parent only. In the PDM, the resulting table, Title, includes a column,
Periodical, that indicates if a title is a periodical or not. It also
includes columns related to periodicals or nonperiodicals.

What you learned In this section, you learned how to:

+ Define generation parameters according to how you want to generate
objects in the PDM

¢ Generate a PDM from a CDM
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Chapter 10 Generating the PDM from the CDM

Save and close the PDM

Where you are
Chapter 10 Generating the PDM from the CDM
Generate the PDM
= Save and close the PDM
Exit DataArchitect

You will save and close the generated PDM.

1  Select File» Save from the menu bar.

This saves the PDM.

2  Select File»Close from the menu bar.

This closes the PDM window and returns you to the CDM window.
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Exit DataArchitect

Exit DataArchitect

Where you are
Chapter 10 Generating the PDM from the CDM
Generate the PDM
Save and close the PDM
® Exit DataArchitect

You will close the CDM and exit DataArchitect.

¢ Select File» Exit from the menu bar.

You exit the DataArchitect application.

You have now completed the CDM tutorial.
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PART TWO

PDM Tutorial

This part is an introduction to the DataArchitect physical data modeling
environment.



CHAPTER 11

About the PDM Tutorial

What is a PDM?

Why build a PDM?

This tutorial is a series of nine lessons in which you learn how to use
DataArchitect to create a Physical Data Model (PDM).

In this tutorial, you complete the PDM that you generated in the CDM
tutorial. If you did not do the CDM tutorial, you can start with the PDM
tutorial.

You learn how to denormalize the generated PDM so that you can archive
data, speed up access to information in the database, and ensure database
integrity.

A PDM represents the physical structure of the data as it will be implemented
by a Database Management Systems (DBMS). The PDM takes into account
the features and physical restrictions of the DBMS of your choice.

In a PDM, you can optimize database characteristics by customizing tables,
columns, indexes, referential integrity, views, physical storage, triggers, and
stored procedures. Database generation and modification procedures
implement these characteristics in the way best adapted to the DBMS of your
choice.

You build the PDM based on the solid design framework of the Conceptual
Data Model (CDM). You can update the CDM and preserve modifications to
the PDM, thereby updating your design without losing any details of physical
implementation.
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What you will do

What you will do

Chapter 12

Chapter 13

Chapter 14

Chapter 15

Chapter 16

Chapter 17
Chapter 18

Chapter 19

112

You will outline your approach to physical implementation by preparing a list
of physical considerations to be taken into account in the PDM.

You will start DataArchitect and open the tutorial PDM. This PDM presents
the physical structure of a publishing enterprise.

You will specify model preferences,options, and properties. You will save
the model.

You will denormalize your PDM by adding a table, assigning it columns
including a primary key column.

HISTORY
TTLE_ISEM 2pk=
TITLE_PRICE
TITLE_TEXT
TOTAL_SALES

Next, you will create a primary key index for the new table. You will also
denormalize the PDM for performance enhancement by creating additional
indexes.

You will define a reference that indicates how this new table relates to the
rest of the database. You will define referential integrity for another
reference.

You will create a view to allow users to view subsets of tables without giving
them full access to the tables themselves. You will create calculated columns
in the view.

'd BOOK_SALES ™
TITLE.TITLE_ISBN char(12)
TITLE.TITLE_TEXT varchar(80)

sum(SALE SALE_AMOUNT) TOTAL_AMT
sum{3ALE SALE_QTY) TOTAL QTY

B TITLE
\B SALE y

You will create extended attributes and save them in a file.

You will define a cascade-type trigger and you will preview the trigger script.
You will create a stored procedure which adds data to the calculated column
in the new table. You will generate the triggers and procedure in a script file.

You will define a server expression for a business rule and you see how this
validation rule applies to a table. You will generate the script which you can
use to generate a database.



Chapter 11  About the PDM Tutorial

Chapter 20 You will create data profiles and define test data generation sources for each
profile. You will assign the data profiles to appropriate columns in a table,
then generate a script which you can use to generate test data in a database.
You will then save and close the PDM.

How long it will take

You can do this part of the tutorial in one sitting in about one hour and a
guarter. You can also stop after any lesson, save your model, and continue at
another time.

What you will learn

You will learn basic DataArchitect techniques for modifying a PDM,
including:

*

* & 6 6 o 0o o

How to add tables and columns to a PDM, and how to designate primary
keys

How to create references and define referential integrity
How to create indexes

How to create and customize a view

How to create extended attributes

How to create, preview, and generate a trigger script
How to generate a database creation script

How to generate a test data creation script
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Setting up

Setting up

114

Before you begin, make sure that the files you need for the exercises are on
your hard disk. When you install DataArchitect, these files are installed in
subdirectories of your PowerDesigner directory. When you have finished
with this tutorial you can delete them if you want.

The PDM tutorial uses the following files:

File Subdirectory Description

PDMBEFOR.PDM | PD6\EXAMPLES | Starting tutorial PDM

PDMAFTER.PDM PD6\EXAMPLES Finished tutorial PDM




CHAPTER 12
Defining Physical Implementation

You build a Physical Data Model (PDM) to address the details of physical
implementation. To do this, you need to decide:

+ What sort of information you need to store

+ What sort of information you need to retrieve, how often, and in which
form

¢ How will the database be accessed

When the particular needs of implementation are clear, you can begin to
develop the PDM.

Physical You will start this tutorial with a PDM that is the model of the information

description system for a publishing company. The database that implements this
information system will be used by publishers and their staff, as well as by
book stores and distributors.

The database must provide fast access to information about titles and sales.

Implementation In the course of the PDM tutorial, you will address the following
issues implementation issues:

+ Store and update historical information on sales for each title
+ Provide consultation-only access to a limited amount of information

+ Control updates and deletion
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CHAPTER 13

How to Begin the PDM Tutorial

You will begin the tutorial by running DataArchitect and opening the tutorial
Physical Data Model (PDM).

In this chapter you will:

+ Open the tutorial PDM

+ Define PDM preferences and options
+ Define PDM properties

¢ Save the tutorial PDM

How long will it take?
About 5 minutes.
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Open the tutorial PDM

Open the tutorial PDM

118

Where you are
Chapter 3 How to Begin
® Open the tutorial PDM
Define PDM preferences and options
Define PDM properties
Save the tutorial PDM

Click the DataArchitect program icon.

The DataArchitect window appears. It contains an empty CDM
workspace. You have to open the PDM workspace.

Select File>Physical Model>Open.

A file selection window appears.

Select PDMBEFOR.PDM from the EXAMPLES directory.

Click OK.
DataArchitect displays the model in the PDM workspace.




Chapter 13 How to Begin the PDM Tutorial

5

Click the Zoom All tool in the toolbar.

The whole model fits in the PDM workspace.

AOYECHED
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FINT) SRS | o) (TTE PRICE | JEEL ek
g TINLE_KOTES ] FRHANE
T&, OADER TITLE_FLBDATE s
T, FERCENT FERIODICAL e
B NONF G CLLECTION ™. SALE
.]. FER_FORMAT BrliEa s gk
SLTHER FER FREQUEMIY ETOR_D ol
] gk TITLE_ISEM ik
AT LhesdE E‘;'—I f-':"‘,,,,,,,:TE
AL FALANE g Al
M EICGRAPH SALE_TEAMS
AL ALWENHCE EALE oTY
A ADCAEES T
[ b pnj
STATE
POETALCODE
M_I_I-'H'_:u:
DISCOURT ETORE
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-l STOR_ID Ll T
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Your screen looks different

slightly different.

All the screen captures in this book were taken in a Windows 95
environment, with an 800x600 screen resolution. The appearanc
proportions of the images which appear on your screen may be

e and
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Define PDM preferences and options

Define PDM preferences and options

120

Where you are
Chapter 3 How to Begin
Open the tutorial PDM

Define PDM properties
Save the tutorial PDM

=® Define PDM preferences and options

Before you begin working, you will define certain display preferences and

model options for the PDM.

&~ For a complete description of all PDM preferences and options, see

PowerDesigner DataArchitect User's Guide

1  Select File>Display Preferences from the menu bar.

The Display Preferences dialog box appears.

2 Select or clear checkboxes and radio buttons so that the dialog box looks

like the one shown below.

Dizplay Preferences [ %]
General | Symbolsl Mame & Codel
¥V Auto-adjust to text I™ Keep center ™ Keep aspact ratio
V' Printer fonts Page scale: |1DD %
Display: © Name  Code
— Table

¥ Frimary keys [ MULLAHOT HULL
¥ Calumns " Data types

[ Indexes [~ Owner
[T Domaine M Kep indicators

— Wiew
V' Tables ™ Owner

¥ Columng ¥ Data types V¥ Fomulas

— Reference
" Mame M L ; Mode: (¥ Relational
™ Join ™ Referential integrity © CODASYL

ak. I Cancel | Help I

These display preferences display object codes and identify all keys.

They adjust tables and views to fit their text.
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6

Click OK.

Select File>Model Options from the menu bar.

The Model Options dialog box appears.
Select or clear checkboxes and radio buttons so that the dialog box looks
like the one shown below.

Model Dptions

General | Namel Codel Editorl

— Column # Domain

— Reference

[~ Enforce ¥ Urigue Code
Use: ¥ Datatype ¥V Auto-migrate FK.
™ Check [~ Domain
" Fules " Check
[~ Mandatory ™ Rules
I Extended I Extended

— Default Data Type

— Delets options

|<undefined> j V' Confirm
Length: I'I Precigion: |1_
ak I Cancel Help

Click OK.
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Define PDM properties

Define PDM properties

Where you are

Chapter 3 How to Begin

Open the tutorial PDM

Define PDM preferences and options
» Define PDM properties

Save the tutorial PDM

1  Select Dictionary>Model Properties from the menu bar.

The Model property sheet appears.

Definition | Descriptionl Annotationl

Project name: | j
Project code: I j
Databaze name:  Spbase SOL Anpwhere 5.5

Mame: IStarting model for PO tutarial j
Code: [Fom_EEFOR =
Label: I

Authar: I Wersion: I

Language: I English [United States) j

File: C:\Pw RS \PDENE Ramplestpdmbefor. pdm

Created:  3/27/97 4:48 PM Modified: 3/28/37 4:12 P

Script | Optiong | Extended |
Cancel | Apply Help

2 Type Publications in the Project Name box.

This is the name of the project to which the PDM belongs.

3 Click the j button at the end of the Project Code box.

This sets the code equal to the name.
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Chapter 13 How to Begin the PDM Tutorial

8

Type Tutorial in the Name box.
This is the name of the PDM.

Click the J button at the end of the Code box.

This sets the code equal to the name.

Type your name in the Author box.

This indicates that you are the owner of the PDM.

Type 1.0 in the Version box.

This indicates that this is the first version of the PDM.

Model Properties [ %]

Definition | Descriptionl Annotationl

Project name: |Publications

Project code: IF'UBLID’-\TIDNS

Ll

Databaze name:  Spbase SOL Anpwhere 5.5

Mame: IT utarial j
Code: [TUTORIAL
Label: I
Authar: Iuser Wersion: I‘I .0
Language: I English [United States) j
File: C:\Pw RS \PDENE Ramplestpdmbefor. pdm
Created:  3/27/97 4:48 PM Modified: 3/28/37 4:12 P

Script | Optiohs | Exztended |

ak | Cancel Apply Help

Click OK.
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Save the tutorial PDM

Save the tutorial PDM

Where you are
Chapter 3 How to Begin
Open the tutorial PDM
Define PDM preferences and options
Define PDM properties
» Save the tutorial PDM

You will save the tutorial PDM in another file. This leaves the original
tutorial PDM intact so you can use it again if you want to redo the exercises.

1  Select File»Save As.

The File Save As dialog box appears.

2 Type TUTORIAL.PDM in the File Name box.

This is the name of the file in which you will work and save your
modifications.

3 Click OK.
This saves your model in the TUTORIAL.PDM file.

Save your work
Save your work periodically while doing these exercises by selec
File>Save.

ng
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CHAPTER 14

Creating a Table in the PDM

About indexes

You will create a table in the PDM. This table will be named HISTORY and
will contain a record of all sales.

You will create this table directly in the PDM because you only use it to store
data. It has no role in the functional structure of the database and, therefore,
does not form part of the conceptual model.

You will also add columns to the table and designate a primary key.

Adding objects to a PDM in this way is called denormalizing the physical
model.

Indexes speed up access to data when you are searching for information in
tables. You can create indexes for particular columns of a table in the PDM.
When you perform a search in a table, for example, by executing a SQL
SELECT query, the search process can find the rows matching the search
criteria more quickly when the model columns are indexed. It is much more
efficient to scan an index than to scan through the data contained in each row.
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Add a table

Primary and
foreign key indexes

126

DataArchitect automatically creates indexes for primary and foreign key
columns, but you can also create your own indexes for other columns,
depending on the type of information you are likely to want to access in the
database.

For example, if you want to search for an author in the database you are
likely to perform a search on the author's last name. In this case you would
index the columns which contain this information.

In this lesson you will:

¢ Add atable

¢ Add columns to the table

+ Designate a primary key

+ Create a primary key index

+ Create an alternate key index

How long will it take?
About 15 minutes.




Chapter 14 Creating a Table in the PDM

Add a table

Where you are

Chapter 14 Creating a Table in the PDM
» Add a table

Add columns

Create columns

Create a primary key index

Create an alternate key index

You will add the HISTORY table to the PDM.
1 Click the Table tool in the tool palette.

2 Click the PDM workspace underneath the TITLE table symbol.

A table symbol appears at the click position.

TITLE
TITLE_ISEN <pk>
PUB_ID <fk
TITLE TEXT

TITLE_TYPE

TITLE_FRICE

TITLE_NOTES
TITLE_PUBDATE
PERIODICAL
NONP_COLLECTION
PER_FORMAT
PER_FREQUENGY

TAE_103

The table has the code TAB_wheren is a number assigned in the
order of creation of objects.

3 Click the Pointer tool in the tool palette.
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Add a table

What you learned

128

Double-click the table symbol.

The Table Properties dialog box appears.

Type History in the Name box.

This is the name of the table.

Table Properties

Definition | Descriptionl Annotationl

Model:
Qrigin:
Mame:
Code:
Label:
Owner:

Mumnber:

Frimary key

constraint name:

Tutarial

Click the J button at the end of the Code box.

This sets the code equal to the name.

IH istany

|HIsTORY

NN

|
I[None] j J
I ¥ Generate table

|Pr_T2E_109

VU zer-defined

Eolgmnsl Indexes | ﬂlt.l_<e_l,ls| E;tendedl Options | Trigger | LCheck |

Script | Fill |

oK I Cancel

Apply

Help

7 Click OK.

The table symbol appears in the PDM workspace.

HISTORY

In this section

+ Customize a PDM by adding a table to store data

, you learned how to:
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Add columns

Where you are
Chapter 14 Creating a Table in the PDM
Add a table
®» Add columns
Create columns
Create a primary key index
Create an alternate key index

You will add the columns TITLE_ISBN number and TITLE_TEXT to the
HISTORY table.

1 Double-click the HISTORY table symbol.

The Table Properties dialog box appears.

2  Click the Columns button.

The Columns of the Table dialog box appears. The table does not yet
have any columns so the list is empty.

Columns of Table: History

MName | Code | Data Type |F'|F|M|D|N|i|
= 3 [l ol il

LTI

[

Inseit | Delete | Add.. | W v F ]| ]F] 2]

Label: I

Damain: I[None] j J Length: I Frecision: I_

[~ Brimarpkey [~ Fosignkey T Mandator ¥ Display

Check I Al ke_l,lgl Egtendedl Desgribel Annoﬁatel ak I Cancel | Help |
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Add columns

3 Click the Add button.

The Selection of Columns dialog box appears. It shows the name of each
column, its code, and the tables to which it belongs.

Display table: € Name & Code

Name | Code | Table [«

= Huthor D Al_ID AUTHOR ||
12 lauthor Last Name AlL_LMAME ALUTHOR
12 twuthor First Name Al_FHAME AUTHOR
14 twuthor Biegraphy All_BIOGRAPH AUTHOR
|5 Awuthor Advance Al_ADVANCE AUTHOR
16 jawthor Address AU_ADDRESS AUTHOR
|7 City CITY AUTHOR
18 |State STATE AUTHOR

|9 [Postal Code POSTALCODE AUTHOR j

ﬂil_bl M| Sotby ¢ Mame ¢ Code  Table

Cancel |

4 Click the Table radio button.

This sorts the columns alphabetically by table.

5  Scroll down the list to the columns in the TITLE table.
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Chapter 14 Creating a Table in the PDM

Click the number at the beginning of the Title ISBN line.

Press cTRL while you click the number at the beginning of the Title Price
line.

Press cTRL while you click the number at the beginning of the Title Text
line.

Selection of Columns

Display table: € Name ' Code

Mame | Code | Table [a]
44 |Title Type TITLE_TYFE TITLE
45 |Periodical FERIODICAL TITLE
46 |Book collection MNOMP_COLLECTION TITLE
47 |Periodical Farmat FER_FORMAT TITLE
48 [Periodical Pub Frequency PER_FREGUEMCY TITLE
45 |Title Motes TITLE_MOTES TITLE

50 |Title Publication Date TITLE_PUBDATE TITLE _I
+ TITLE_ISEN TITLE

52 uthar | AU_ID TITLEAUTHOR LI

illl_}lil Sortby: € Mame ( Code @ Table
Eancell

Click OK.

The selected columns appears in the list of columns.

Columns of Table: History
Name | Caode | Data Type PF[M]o[N] =]

1 [Title Price TITLE_PRICE numenic(5.2) BT T
2 |Title Test TITLE_TEXT varchar80) FECOCCMIT
B Yl TR— TITLE ISEN cha12] Brrrer
- [~

Insert | Delete | pdd.. | W] F] ]| e]F] 2]
Label: I
Diomnain: I[None] j J Length: I‘I2 Frecision: I_

[~ Primarykey [ Foeionkey [ Mandatony ¥ Display
Check | Al keys | Eztended | Describe | Annotate | 0k I Cancel | Help |

Click the number at the beginning of the Title ISBN line.

An arrow appears at the beginning of the line and the whole line is
highlighted.
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What you learned
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9 Click the 2] button.

Title ISBN move to the top of the list. This means it will generate the
first column in the database table.

10 Select the Primary key checkbox in the bottom part of the dialog box.

A check appears in the P and M columns. The check in the P column
indicates that Title ISBN is the primary key.

Columns of Table: History
MName Code Data Type F'|F|M|D|N|i|
> 2 |
2 |[Title Price TITLE_PRICE nurmeric(5,2) BECTCIIT
3 |Title Tewt TITLE_TEXT varchar80] ECCCMIT
[
Inseit | Delete | Add.. | W avlm] w4 #] 2]
Label: I
Damain: I[N j J Length: I'I2 Frecision: I_
v ¥ Mandatory ¥ Display
Check I Al keys I Egtendedl Desgribel Annoﬁatel ak I Cancel | Help |

Mandatory values
Mandatory values translate to a Not null field in most SQL databgses.

11 Click OK in each of the dialog boxes.

This saves the column definition. The HISTORY table symbol appears
in the PDM workspace. The fact that TITLE_ISBN is underlined and has
the symbol <pk> next to it indicates that it is a primary key column.

HISTORY
TITLE_ISBM  =pk=
TITLE_PRICE
TITLE_TEXT

In this section, you learned how to:
¢ Add an existing column to a table in the PDM

+ Change the order of columns in a table
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Create columns

Where you are
Chapter 14 Creating a Table in the PDM
Add a table
Add columns
» Create columns
Create a primary key index
Create an alternate key index

You will create a new column in the HISTORY table.

1 Press cTRL while you double-click the HISTORY table symbol.
The list of columns in the HISTORY table appears.

Columns of Table: History
Data Type P|F|M|D|N|A|
[=[TITLE_ISEM char[12) v W v
Title Price TITLE_PRICE nurmeric(5,2) CrCvi
Title Text TITLE_TEXT varchar80] CrCCVT
Inseit | Delete | Add.. | W avlm] w4 #] 2]
Label: I
Damain: I[None] j J Length: I'I2 Frecision: I
¥ Brimarpkey [~ Fosignker W Mandatony ¥ Display
Check I Al keps I Egtendedl Describe | Annotate I ag I Cancel | Help |

2 Type Total Sales in the Name column of the first blank line.

3 Click the Code column.
Click the J button that appears in the Code column.

This sets the code equal to the name, with lowercase characters replaced
by uppercase and the space replaced by an underscore.
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4 Select AMOUNT from the Domain dropdown listbox in the bottom part of
the dialog box.

The data type column displaysmeric(8,2) which is a data type
available for the target database (in this case, Sybase SQL Anywhere).

Columns of Table: History
Name | Caode | Data Type PF[M]o[N] =]

Title ISEM TITLE_ISEN char[12) [ET VI

Title Price TITLE_PRICE rumeric(5.2) FECOCCMIT

Title Test Tl varchar80) FECCCME

Total S ales fi nurmeric(2.2] ECCCMIT

cafral—
+

[~
Insert | Delete | pdd.. | W] F] ]| e]F] 2]
Label: I
Diomnain: I.ﬂMDUNT j J Length: IB Frecision: |2_

[~ Primarykey [ Foeionkey [ Mandatony ¥ Display
Check | Al keys | Eﬁtendedl Describe | Annoﬁatel 0k I Cancel | Help |

5 Click OK in each of the dialog boxes.
In the PDM workspace, the table symbol contains the new column.

HISTORY
TTLE_ISER Zpk=
TITLE_PRICE
TITLE_TEXT
TOTAL_SALES

What you learned In this section, you learned how to:
¢ Create a new column
+ |dentify a column by a name and a code

¢ Attach a column to a domain
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Create a primary key index

Where you are
Chapter 14 Creating a Table in the PDM
Add a table
Add columns
Create columns
=® Create a primary key index
Create an alternate key index

You will define a primary key index for the HISTORY table.

1 Double-click the HISTORY table.

The Table Properties dialog box appears.

Table Properties [ x|

Diefinition | Descriptionl Annotationl

odel: Starting model for PDM tutorial

Qrrigin:

Mame: j
Code: [HIsTORY j
Label: I

Owrer: I[None] j J

Mumber: I— V¥ Gererate table

Pimakey [Pk _HISTORY I~ Userdefined

Colgmnsl Indexes | Alt.l_ieysl Eﬁtendedl Options | Trigger | LCheck |

Script | Fill |

ok I Cancel Loy Help
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Create a primary key index

2  Click the Indexes button.

The Indexes of the Table dialog box shows that this table has no indexes.

Indexes of the Table: HISTORY
 List of indexes
Mame | Code [PIF[a]u]c[n] <]
> =l COCCCT
[ | =l
Inzert | Delete | I(I 4 I » |1| ililllililil
Label: |

[~ FErimary kep [~ Foreignkey [ gltematekey ™ Urnique [T Cluster

I List of columng
& |ser-defined © Linked to: I[None object] j

Mo Mame Code Sort

Add... | [elete | Sort: % dscending € Descending illl
thionsl Bules | Desgribel Anno;atel ak I Cancel I Help |

3 Click the first blank line in the list.

An arrow appears at the beginning of the line.

4 Type HISTORY_PK in the Name column.
Click the Code column.

Click the J button that appears in the column.
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6

Select the Primary Key checkbox.

The Unique checkbox is selected automatically. The index History PK
is automatically linked to the primary key TITLE_ISBN.
TITLE_ISBN appears in the List of Columns.

Indexes of the Table: HISTORY
— Ligt of indexes
Mame | Code [PIF[a]u]c[n] <]
# |Histary_PK HGT0RT PR MOV
[ | =
Inset_| _Dekte | T 53 L Jei 5 e K2 4 2
Label: |

¥ Erimary kep [~ Foreignkey [ Altematekey W Urnigue [T Cluster

r List of columns
 |ser-defined & Linked to: IPrimaly ke ﬂ

Mo Mame Caode Sart

1 Title SBM TITLE ISEN

fdd.. Delete | Sort: % Ascending © Descending Llll
thionsl Bules | Desgribel Anno;atel ak I Cancel | Help |

Click OK in each of the dialog boxes.

You return to the PDM workspace.
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Create an alternate key index
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Where you are
Chapter 14 Creating a Table in the PDM
Add a table
Add columns
Create columns
Create a primary key index
® Create an alternate key index

The column that contains author last names is not automatically indexed
because it is not a primary or a foreign key. To be able to search for an author
more quickly when you only know the author's last name, you will create an
index for this column.

1 Double-click the AUTHOR table.

The Table Properties dialog box appears.

2  Click the Indexes button.

The Indexes of the Table dialog box displays the indexes belonging to
the table. This list shows that the primary key is indexed.

Indexes of the Table: AUTHOR

i List of indexes

BEM 2 THOR P [EIEUTHOR_PK.
|

Inzert | Delete | |4| 4 I ¥ |1| ilililililil

Label: I

¥ Primary key [ Forsignkey [ Allematekey W Unique [ Cluster

i List of columns
" Userdefined & Linkedto: IPrimary kep j

Mo Mame Code St

1 Author D

Add.. Delete | Sort: % Ascending © Descending illl
ﬂptionsl Bules | Desgibel Annoﬁatel ak I Cancel | Help |
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3 Click the first blank line in the list.

An arrow appears at the beginning of the line.

4 Type AU_LNAME_AK in the Name column.
Click the Code column.

Click the J button that appears in the column.

This is the name of the index for the last names of the authors.

Indexes of the Table: AUTHOR
— Ligt of indexes
Mame | Code [PIF[a]u]c[n] <]
1 [aUTHOR_PK AUTHOR_PK. VMW
+ |5U_LNAME_&K A1 LNAKE &K ECCCOCCE
| =l
nsen_| _petet | IR ke A2 RS
Label: |

[~ FErimary kep [~ Foreignkey [ gltematekey ™ Urnique [T Cluster

I List of columng
& |ser-defined © Linked to: I[None object] j

Mo Mame Code Sort

Add... | [elete | Sort: % dscending € Descending illl
thionsl Bules | Desgribel Anno;atel ak I Cancel I Help |

5  Select the Alternate Key checkbox.
The Unique checkbox and the User-Defined radio button are selected
automatically.

6 Click the Add button.

The List of Columns dialog box appears. It lists all the columns in the
table.
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Create an alternate key index

7 Select Author Last Name.
This is the column to which you want to attach the AU_LNAME_AK

index.
List of Columns
Mo Mame Code
1 Author Address Al_ADDRESS
2 Author Advance Al_ADWVAMCE
3 Author Biography Al_BIOGRAPH
4 Author First Mame
5
£
7
i ity
9 Postal Code POSTALCODE
10 State STATE
Sortby: € Mame * Code Cancel |

8 Click OK.

You return to the list of indexes of the table. Author Last Name appears
in the List of columns. ASC in the Sort column means that the index
sorts the last names of authors in ascending alphabetic order from

Ato Z.
Indexes of the Table: AUTHOR
— List of indexes
Name | Code [PlFulc[n] <]
1 [AUTHOR_PK AUTHOR_PE, ML LT
# A0 L NAME_AK AT TNAME S " C CC T
inset | Delete | | <] v ]v] F|2| 2|7 2]

Label: I

[~ Primary key I~ Foreign key [ Unique [~ Cluster

i List of columns
Mo  Mame Code Sart

1 Author Last Mame Al LMARE

Add.. Dglete | Soit: % Agcending € Descending llll

DOptioks | Bules | Desgribel Anno;atel

aK I Eancell Help |
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What you learned

9

Click OK in each of the dialog boxes.

You return to the PDM workspace.

In this section, you learned how to:

*

Speed access to information in the database by creating indexes for the
columns storing relevant data

Identify an index by a name and a code
Select the columns you want to index

Define how values inside the indexed columns are sorted
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CHAPTER 15
Defining a Reference and Referential

Integrity

About references

About referential
integrity

A referencesymbolizes the link between two tables.

You can create a reference between two tables in the PDM. You do this when
you want one column to refer to another. When you create a reference, the
primary key in the parent table migrates to a foreign key in the child table.

Referential integrity dictates what happens to a foreign key column in a
child table when you update or delete the value of the corresponding primary
key column in the parent table.

Store ID is the primary key column in the STORE table. It contains the
unique identification code of a store. A reference links the value of the Store
ID in the STORE table to the Store ID column in the DISCOUNT table.
Using the referential integrity options, you can specify that if you delete a
store from the STORE table, you also delete all of its corresponding records
in the DISCOUNT table.

In this lesson you will:
¢ Create areference

¢ Define referential integrity

How long will it take?
About 5 minutes.
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Create a reference

Create a reference

Where you are

Chapter 15 Defining a Reference and Referential Integrity
» Create a reference

Define reference properties

Define referential integrity

You will create a reference between the HISTORY and TITLE tables. This
reference represents the sales history for each title.

[Re| 1  Click the Reference tool in the tool palette.

2 Drag areference link from HISTORY to TITLE.

TITLE
TITLE_ISEN <pk>
PUE_ID <fk
TITLE TEXT

TITLE_TYPE

TITLE_PRICE

TITLE_NOTES
TITLE_PUBDATE
PERIODICAL
NONP_COLLECTION
PER_FORMAT
PER_FREGQUENGY

@]

HISTORY
TITLE_ISBM Zpk k=
TITLE_PRICE
TITLE_TEXT
TOTAL_SALES

HISTORY is the child table and TITLE is the parent table.
TITLE_ISBN is the primary key of both tables. It is also the foreign key
in th HISTORY table as indicated by the symbol <pk,fk>.

What you learned In this section, you learned how to:
+ Create a reference between two tables

+ Identify the parent and child tables in a reference
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Define reference properties

Where you are
Chapter 15 Defining a Reference and Referential Integrity
Create a reference
=» Define reference properties
Define referential integrity

You can define a name for a reference. This makes it easier to identify.

1  Click the Pointer tool in the tool palette.

2  Double-click the reference link between HISTORY and TITLE.

The Reference Properties dialog box appears.

Reference Properties E

Diefinition | Descriptionl Annotationl

Child

| Parent | .
Primary key ""—|— Primary ke
Foreign kep

TITLE | HISTORY |
Name: [Ref_208 = Code: [REF_208 [=]
Label: I
Frimary key columns Fareign key columns
LCreate | Delete | ﬂﬂﬂﬂ illl
[riTLE_isen 2| = [TITLEIsen 2]

¥ Generate reference

1ntegrit_l,l| Egtendedl Bulzs |

ok I Cancel Loy Help
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3 Type Title Sales in the Name box.

4  Click the J button at the end of the Code box to set the code equal to the
name.

Reference Properties [ %]

Definition | Descriptionl Annotationl

Child

| Parent |
Primary key ""—|— Primary ke
Fareign key

TITLE | HISTORY |
Mame: [Tile sales = | Code: [TITLE_SALES
Label: |
Frimary key columns Foreign key columns

LCreate | Delete | ﬂil_blll illl
[TITLE_ 15BN 2| = [TTLEisEN 2]

W Generate ieference

Intearity | E;tendedl Bules |

ak | Cancel Apply Help

5 Click OK.
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Define referential integrity

Where you are
Chapter 15 Defining a Reference and Referential Integrity
Create a reference
Define reference properties
» Define referential integrity

You will use the referential integrity options to implement cascade update
when a store is deleted. Since discounts are specific to store, if you delete a
store you delete its associated discounts.

1  Double-click the reference link between DISCOUNT and STORE.

The Reference Properties dialog box appears.

Reference Properties E

Diefinition | Descriptionl Annotationl

Child

| Parent | .
Primary key ""—|— Primary ke
Foreign kep

STORE | DISCOUNT |
Mame: IStole Dizcount j Code: ISTDHE_DISC j
Label: I
Frimary key columns Fareign key columns
LCreate | Delete | ﬂﬂﬂﬂ illl
[sToR_ID 2| -[sToRD 2]

¥ Generate reference

1ntegrit_l,l| Egtendedl Bulzs |

ok I Cancel Loy Help

2 Click the Integrity button.
The Referential Integrity dialog box appears.

The Restrict radio buttons indicate to use Restrict referential integrity by
default.
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Define referential integrity

3 Click the Cascade radio button in the Delete Constraint groupbox.

This means that if you delete the Store ID in the STORE table you delete
the corresponding records in the DISCOUNT table.

Referential Integrity

Parent Child
Primnary key ""—|— Primary ke
Foreign key

[ ETIEE 1 DISCOUNT |
Mame: |Store Dizcaunt j
Code: [STORE_DISC [=
Constraint name: IFK_DISEDUNT_STDHE_DIS_STDH I User-defined
— Cardinality

MHurnber of children: Iinirnunin: IU b ERirrirn: In
— Update constraint

" None & Restrict ¢ Cascade & Setnull € Set default

i Delete constraint

" None & Restrict " Cascade ¢ Setnull = Set default
V' Mandatory parent ¥ Change parent allowed ™ Check on commit
aK Cancel Help

4 Click OK in each of the dialog boxes.
You return to the PDM workspace.
What you learned In this section, you learned how to:

+ Define what happens to related values in child tables when you delete or
modify a value in the parent table
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CHAPTER 16
Creating a View

About views

What happens
when you create a
view

A view is an alternative way of looking at the data in one or more tables. A
view contains a subset of columns from one or more tables. You can create a
view to allow users to see subsets of tables without giving them full access to
the tables themselves.

Creating a view is equivalent to defining a SQL SELECT query to select
objects in the database. When you create a view you select the tables and
columns you want to include in the view. In this lesson, you will create a
view on the TITLE and SALES tables. This view generates a SQL query
which automatically selects all the columns in these tables and displays a
graphic symbol representing the view.

In this lesson you will:

+ Compose the view

¢ Customize the view

+ Create calculated columns
.

Preview the SQL query

How long will it take?
About 10 minutes.
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Compose the view

Compose the view

150

Where you are

Chapter 16 Creating a View
®» Compose the view

Customize the view

Create calculated columns

Preview the SQL query

You will compose a view of the TITLE and SALES tables.

1

2

Select the TITLE table symbol.

Press sHIFT while you click the SALE symbol.

Both table symbols are selected.

Select Dictionary>Views>New from the menu bar.

A view appears in the PDM workspace. The view lists all the columns
belonging to the selected tables. At the bottom of the view, it lists the
tables.

;7 VIEW 214 ™
TITLE.TITLE_ISBN char(12)
TITLE.PUE_ID char(12)
TITLE.TITLE_TEXT varchar(30)
TITLE.TITLE_TYPE varchar(20)
TITLE.TITLE_FRICE nurneric(d,2)
TITLE TITLE_MOTES long warchar
TITLE.TITLE_FPUBDATE date
TITLE.PERIODICAL nurneric(1)
TITLE.PER_FORMAT char(20)

TITLE.PER_FREQUENCY char(20)
TITLE.NOMP_COLLECTION — warchar(g)

SALE.SALE_ID srallint
SALE.STOR_ID char(12)
SALE.SALE_DATE date
SALE SALE_AMOUNT nurneric(d,2)
SALE SALE_TERMS varchar(B0)
SALE SALE_QTY numeric
B TITLE

.\\EI SALE J

The view has the code VIEW, wheren is a number assigned in the
order of creation of objects.
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Customize the view

Where you are
Chapter 16 Creating a View

Compose the view

= Customize the view
Create calculated columns
Preview the SQL query

You will customize the view so that it contains only certain columns.

1 Double-click the view symbol.

The View Properties dialog box appears.

2 Type Book Sales in the Name box.

This is the name of the view.

3 Click the J button at the end of the Code box to set the code equal to the

name.

4 Select the Query Only radio button.

This limits access to consultation only.

Disfidion |Dmﬁm'|m-uu.|:-|

pladek T ool
Howe:  [Bood 5ok |
Cada [pooK_selEs _-|
Lt |
Usage 1% sy iy ™ Lt
F Gerasinves T ™ Wit gisfrmd 500
Tabies Doy | G0 | Eseedsd | Bues
[T ] gaem fphe Help
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Customize the view

5  Click the Query button.

A window appears, showing the definition of the view.

it FuwerDienigren Datafichelest || Qe Diclwitam ol lhe Voow BOOEK_SALES" |

THLE_TIT

TE T

TE*SCE

T LK, T

THLE o WTE

[

WOAE Cna BETIDA
i ny

Ll LI
Tatbor Tokires | hose | Gaoo e | Haing | Dods By |
Arvgalabiy coheer Cigren /! Exoyenree diar

¥ lEb,

E TITLE HOTES =

=] |TITLETITLE_jsEu |

The top part of the window shows the graphic symbols representing the
TITLE and SALE tables. The bottom part of the window lists all the
columns included in the view and the tables to which they belong.

152



Chapter 16 Creating a View

6 Inthe Available Columns list, deselect all columns except for the
following: TITLE.TITLE_ISBN, TITLE.TITLE_TEXT, SALE.SALE_AMOUNT,
and SALE.SALE_QTY.

The Column/Expression list displays the selected columns.

SALE.SALE AMOUNT

Tahles Colurnns |Where| Group B_l,ll Havingl Order Byl
Arailable columnz Colurnn / Expression Aliaz Cancel |
TITLE.MOMP_COLLECTION ;l TITLE.TITLE_ISEN

SaLE” TITLE.TITLE_TEXT Help |

Z00m

add | Modiy | Femove | +| 4]

SALE. SalE _OTY

|SALE. SALE_OTY |

7  Click the Where tab.

The Where page shows the link between SALE and TITLE tables by
TITLE_ISBN.

Tablesl Columns  ‘where | Group Byl Havingl Order Byl

Exprezsion 1 Operator E xpression 2

TITLE. TITLE ISBN SALE TITLE ISEM

add | Modty | Bemove | +] 4] Tano T or (]|
| |TITLE TITLE_ISBN =l x| |sALETITLE_ISBN B

8  Click the Group By tab.
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Customize the view

9  Select TITLE.TITLE_ISBN and TITLE.TITLE_TEXT in the List of Available
columns.

This choice groups titles by ISBN number and title.

Tablesl Columnsl ‘where  Group By | Havingl Order Byl Ok,

Available columns Colurnn
TITLE TITLE |SEBM

Cancel

Help

TITLE TITLE TEXT
TITLE.TITLE_TYPE
TITLE.TITLE_PRICE Zo
TITLE.TITLE_NOTES
TITLE.TITLE_PUBDATE
TITLE.PERIODICAL
TITLE.MONP_COLLECTION

ek

TITLE PER FORMAT =
10 Click OK.
You return to the PDM workspace. The view now only lists the selected
columns.
;7 BOOK_SALES ™
TITLE. TITLE_ISEN char(12]
TITLE.TITLE_TEXT varchar(80]
SALE.SALE_AMOUNT  numericis 2)
SALE SALE QTY AUrrErc
B TITLE
\8 sALE Y,
What you learned In this section, you learned how to:

+ Restrict access to information further by including only certain columns
in a view

+ Optimize the view using a GROUP BY statement
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Create calculated columns

Where you are
Chapter 16 Creating a View
Compose the view
Customize the view

® Create calculated columns
Preview the SQL query

You will add two calculated columns to the view. One column will contain
the total number of books sold for a title. The other will contain the total
dollar amount of sales for a title.

1 Double-click the view symbol.

The View Properties dialog box appears.

2 Click the Query button.

The query window opens to the Columns page.

3 Select SALE.SALE_AMOUNT in the Column/Expression list.

Tahles Colurnns |Where| Group B_l,ll Havingl Order Byl
Arailable columnz Colurnn / Expression Aliaz Cancel |
TITLE.PER_FREQUENCY | [TITLE.TITLE_ISEM

TITLE MOMP_COLLECTION TITLE.TITLE_TEXT Help |
SALE SALE SALE AMOUNT

SalLESALE_ID SalE SalE_QTY |

SALE.STOR_ID oo
SALE.TITLE_ISEN

add | Modiy | Femove | 4] 4]

|SALE. SALE_AMOLINT |

4 Type sum(SALE.SALE_AMOUNT) below the Add button.

5 Type TOTAL_AMT in the box below the | putton.
TOTAL_AMT is the alias for the calculated field.
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Create calculated columns

6  Click the Modify button.

The Column/Expression list displays the calculated column.

Tables  Columne |Where| Group B_l,ll Havingl Order Byl

Available columns

Colurnn / Expression Aliaz

TITLE NONP_COLLECTION ;l
SaLE”

SALE.SALE_ID

SALESTOR_ID
SALE.TITLE_ISEN
SALE.SALE_DATE
SALE.SALE_AMOUNT

SALE.SALE TERMS

TITLE.TITLE_ISEN
TITLE.TITLE _TEXT

sumn[SALE. SALE _AMOUNT]
SALE.SaLE_GTY

add | Modiy | Femove | +] 4]

ok
Cancel

Help

Z00m

[ lelee

Jsum(SALE SALE_AMOLUNT) |TOTAL &k
7  Select SALE.SALE_QTY in the Column/Expression list.
Tables  Columne |Where| Group B_l,ll Havingl Order Byl Ok,
Arailable columnz Colurnn / Expression Aliaz Cancel

TITLE NONP_COLLECTION ;I
SaLE”

SALE.SALE_ID
SALE.STOR_ID
SALE.TITLE_ISEN
SALE.SALE_DATE
SALE.SALE_AMOUNT
SALE.SALE TERMS

TITLE.TITLE_ISEN
TITLE.TITLE_TEXT

zurn[SALE SALE _AMOLNT TOTAL &

add | Modiy | Femove | +| 4|

|SALE. SALE_OTY |

8 Type sum(SALE.SALE_QTY) below the Add button.

9 Type TOTAL_QTY in the box below the | putton.
TOTAL_QTY is the alias for the calculated field.
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What you learned

10 Click the Modify button.

The Column/Expression list displays the calculated column.

Tables  Columne |Where| Group B_l,ll Havingl Order Byl

ok

Cancel

Arailable columnz Colurnn / Expression Aliaz
TITLE.MOMP_COLLECTION ;l TITLE.TITLE_ISEN

SaLE” TITLE.TITLE_TEXT

SALESALE_ID S TOTAL &

SALESTOR_ID
SALE.TITLE_ISEN
SALE.SALE_DATE
SALE.SALE_AMOUNT

SALE SALE_TERMS add | dodiy | Bemove | 4| 4]

Help

TOTAL L
Z00m

bl

SALE.SALE_QTY
| [sum(SALE.SALE_QTY)

[roTaL_ar

11 Click OK.

You return to the PDM workspace where t
calculated column.

he view symbol includes the

;7 BOOK_SALES

~

TITLE. TITLE_ISEM char(12)
TITLE.TITLE_TEXT varchar(50)
sUM(SALE. SALE. AMOUNT) TOTAL_AMT
sum(SALE.SALE_QTY) TOTAL QTY

B TITLE

.\\EI SALE

In this section, you learned how to:

¢ Define a column that contains the sum of values in another column

¢ Define an alias for a calculated column
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Preview the SQL query

Preview the SQL query

Where you are

Chapter 16 Creating a View

Compose the view

Customize the view

Create calculated columns
» Preview the SQL query

You will preview the SQL query that the view will generate.

1  Double-click the view.

The View Properties dialog box appears.

2 Click the SQL button.

The SQL Query Editor window appears. The window shows the SQL
query.

VGl Queip I e

S0l 4l | po | g | |

amlect TITLE.TITLE ISAW, TITLE.TITLE TEXT, mum|SALE. SALE AECTHT S|
o SALE.SALE_QTY| TOTAL_QTY

from TITLE, SALE

shece TITLE, TITLE ISEH = SALE.TITLE_I1SEN

graup by TITLE:TITLE_[OOM, TITLE.TITLE TENT

3 Click OK in each of the dialog boxes.

You return to the PDM workspace.
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CHAPTER 17

Defining Extended Attributes

When you generate an application, extended attributes provide you with
additional information about objects in the PDM. You can create your own
extended attributes.

You will create extended attributes that define an alternate label for a column
and a font for a table header. The alternate label can store a coded internal
label or a label in a different language.

To save your own extended attribute definitions, you can export the attributes
to an EXA file.

In this lesson, you will;
+ Create extended attributes
+ Modify the value of an extended attribute

+ Export extended attributes

How long will it take?
About 5 minutes.
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Create extended attributes

Create extended attributes

Where you are

Chapter 17 Defining Extended Attributes
» Create extended attributes

Modify the value of an extended attribute

Export extended attributes

You will create extended attributes that define an alternate label for a column

and a font for a table header. The alternate label can store a coded internal
label or a label in a different language.

1  Select Dictionary>Extended Attributes>List of Attributes.

The Extended Attribute Definition dialog box appears. The Object Type
dropdown listbox indicates that this is the list of attributes for columns.

Extended Attribute Definition
Object type: IColumn ﬂ
M ame | Type Label |M |:|
[~
New | ﬂil_illl Sotby: & Name © Type
Tupe: I[Integer] ﬂ Walue: I _I
Hsedby | Consztants | TTEETT Cancel | Help |

2 Type Alternate Label in the Name column on the first blank line.

This is the name of the extended attribute.

3 Select String from the Type dropdown listbox in the lower part of the dialog
box.

The data type appears in the Data Type column for the extended
attribute.
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4 Type Label for internal use in the Label column.

This is a description of the extended attribute. You will leave the Value
box blank because you do not want to impose a default label.

Extended Attribute Definition
Object type: IEolumn ﬂ
M ame: | Type | Label [M]<]
=+ |Alternate label [String] Label for internal use] r

[

MHew | Delete | ilil_blll Satby: & Mame & Type
Type: I[String] j Walue: I _I
Hzed by | Congtants | ak I Cancel | Help |

5 Select Table from the Object Type dropdown listbox at the top of the
dialog box.

This validates the extended attribute that you defined for columns and
displays a blank list of extended attributes for tables.

6 Type Header Font in the Name column of the first blank line.

This is the name of the extended attribute.

7 Select Font from the Type dropdown listbox.

The data type appear in the Data Type column for the extended attribute.
8  Type Font for table header in the Label column.

9 Click the =l at the end of the Value box.

A standard font selection dialog box appears.
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Create extended attributes

10 Select Arial,10,Bold.

11 Click OK.

In the Value boxArial,10,B indicates that the default value from this
extended attribute is now Arial 10 point in bold.

Exztended Attribute Definition

Object type: ITahIe ﬂ
M ame: | Type | Label [M]<]
% _|Header font (Foni] Fontfortable header T
[
MHew | Delete | ilil_blll Satby: & Mame & Type
Type: [[Font) =l value [rial10B [
Hzed by | Con&tantsl ak I Cancel | Help |

12 Click OK.
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Modify the value of an extended attribute

Where you are
Chapter 17 Defining Extended Attributes
Create extended attributes

= Modify the value of an extended attribute
Export extended attributes

For a particular table, you will assign a value to the extended attribute you
created. In this case, you will associate a different font size for Title table
header.

1 Double-click the TITLE table symbol.
The table property sheet appears.

2  Click the Extended button.

The list of extended attributes for the table shows the extended attribute
Header Font which you just created. The Value box shows the default
value.
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Moadify the value of an extended attribute

3 Type 12 in the place of 10 in the Value box.

In the Value boxArial,12,B indicates that the value of this extended
attribute for the Title table is now Arial 12 point in bold.

Extended Attribute Values
Object type: ITabIe j
Dizplay:
Object: ITitIe j & Name © Code
Attribute Name | Type | Label [M]<]
= [Header font [Font] Fant for table header
L vipf sstav & Name CiTiee
Yalue: IAlial,'I EL] J
Attributes | Congtants | Default | ak I Cancel | Help |

4 Click OK in each of the dialog boxes.
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Export extended attributes

Where you are

Chapter 17 Defining Extended Attributes

Create extended attributes

Modify the value of an extended attribute
® Export extended attributes

To save the extended attributes you export them to an EXA file. You will
export the new list of extended attributes to a new EXA file.

1 Select Dictionary>Extended Attributes> Export Attributes from the menu bar.

A Save As dialog box appears.
2 Type TUTATTRB.EXA.
3 Click OK.

This saves the extended attributes you defined in a file name
TUTATTRB.EXA.

Importing extended attributes

You can import the extended attributes into a PDM by selecting
Dictionary>Extended Attributes Import Attributes and selecting an
EXA file.
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CHAPTER 18
Using Triggers and Procedures

About triggers

About trigger
templates

A trigger is a procedure that goes into effect when you insert, delete, or
update a specified table or column. Triggers enforce referential integrity, for
example, by displaying an error message if you try to update a primary key
column which has an update restriction.

A PDM can automatically generate certain referential integrity triggers
depending on the type of the target database. You can also define additional
user-defined triggers.

You can generate a SQL script containing the triggers, or you can generate
the triggers directly in the database.

A trigger script is based on a template. There is a different template for each
type of trigger: insert, delete, and update. You can create your own trigger
templates or customize an existing template, for example by changing the
type of error message displayed.

A trigger template contains variables for tables, columns, and so on. Before
you generate the script, you can preview the trigger to see the script with the
variables replaced by actual names.

In this lesson you will:
¢ Preview the trigger
+ Create a stored procedure

+ Generate a script for triggers and procedures

How long will it take?
About 20 minutes.
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Preview a trigger

Preview a trigger

168

Where you are

Chapter 18 Using Triggers and Procedures
» Preview a trigger

Create a stored procedure

Generate a script for triggers and procedures

In a previous lesson you defined cascade referential integrity for deletion in
the Sales table. You will now see how this referential integrity can be
interpreted as a trigger.

1

Double-click the STORE table symbol.
The table property sheet appears.

Click the Trigger button.
The List of Triggers dialog box displays triggers defined for the table.

Click the AfterDeleteTrigger.

An arrow appears at the beginning of the line and the trigger script
appears in the bottom of the dialog box. It is not instanciated for this
table.

Takle & [irs I _| i

Taged © Ussdebnsd 1 Delplt a0 Tk peessisl

] Tatle Hewe [T Toe | Tfmllﬂlﬁ_l_l
1’Fe T erdins el T g o

CTORE Ed e T g M CiC
1ive s pval | prdads | e Fuiks_rive i
TOFE tier hpdateT ipge e i

Edt it T ompms i Cr

b  Afcer delsts crigger "sTREIGIERL ¥ for cekls FRTARLEL® =
CrETE CELQDED WIHLWIERY ATEEE O=2181TE OB YITAELEW
referepolng odd a8 old dG=] for =&:h row
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daglare n=ar defined sxpepbion sxoepbion for SOLETLATE 'AF
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relelEPar SRt HErNiI L] -
i | "
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Chapter 18 Using Triggers and Procedures

4 Click the Preview button.

The trigger that will be generated appears. It indicates that a deletion in
the STORE table cascades to deletion in the DISCOUNT table.

5  Click Close.

6 Click OK in each of the dialog boxes.

169



Create a stored procedure

Create a stored procedure

Where you are

Chapter 18 Using Triggers and Procedures
Preview a trigger

= Create a stored procedure
Generate a script for triggers and procedures

You will create a stored procedure that updates the sales statistics in the
HISTORY table.

1 Select Dictionary>Triggers and Procedures>List of Procedures.

The List of Procedures dialog box contains an empty list.

User-Defined Procedures

MName | Code | F | M |:|
+ [=] rr
[~
e | Delete | Iil 1| }I DII Sotbw ¢ Name & Code
Label: | [~ Function
Definition:
create procedure (PROCY (IN <args <types) ﬂ
begin
end
£
-
4 2
Zoom... | Descril_:el Annoﬁatel D efault | QK I Cancel | Help |

2 Type History Proc in the Name column of the first blank line.
This is the name of the procedure.

3 Click the Code column.
Click the J button that appears in the Code column.

This sets the code equal to the name, with lowercase characters replaced
by uppercase, and the space replaced by an underscore.
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4 Type Update sales history for each title in the Label box.

e [ T [FIR[-]
| iy e W TOR_ PRI BT
r— .

then | Duwn | o) Y Eofilpe © Hara ¥ Code
Labed I'.I.'\J-c*r.-a‘r\-'l:l.l!h.-ml-ll‘lr I Furaton
Dlirat iy

reaATE propaedores BPRECY (DN carg: <ouner| d
] 1 T

£

Zon | Dwte | smoiwe | oares | [ ] coea | new |

5  Click the Zoom button.

The Procedure Definition window appears.

6  Select the text in the Definition textbox.

incedun “HISTIHY FRNCT deladian
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Create a stored procedure

2| 7

9

What you learned
.

.

172

Click the File tool.
A File Open dialog box appears.

Select TUT_PROC.TXT from the EXAMPLES directory.
Click OK.

The text of TUT_PROC.TXT fills the Definition textbox.

' Procedure "HISTORY_PROC" definition

Categaory Tables: Descriptiorn:
T ables Table: - OK.
Columns DISCOUNT A thor _I l_l
Joing HISTORY AUTHOR
Functions FICTURE _Conecel |
Operatars FUBLISHER
Business Fules ROYSCHED Help |
SALE =
STORE =l : .

= A e | Edi. | Feven | Defa | Fon. |

create procedurse $PROCE () ‘:J
bhegin

—— oclean up the table

delete from HIZTORY:

-—— fill it again from scratch
insert into HISTORY(TITLE ISEN, TITLE PRICE, TITLE_TEET, TOT
select T.TITLE ISEN,T.TITLE PRICE,T.TITLE TEXT,sum(3.3ALE_AF
from SALE 3, TITLE T
where T.TITLE ISEN = 3.TITLE_ ISEN
group by T.TITLE ISEN, T.TITLE PRICE, T.TITLE_TEZT;

end

.Ilf b
| | _’lJ

Click OK in each of the dialog boxes.

In this section, you learned how to:

Create a stored procedure to update a table

Use the contents of a file for a stored procedure
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Generate a script for triggers and procedures

Where you are
Chapter 18 Using Triggers and Procedures
Preview a trigger
Create a stored procedure
®» Generate a script for triggers and procedures

You will define parameters to generate the script for the triggers and
procedures you defined.

1  Select Database> Generate Triggers and Procedures from the menu bar.
A dialog box containing the generation parameters appears. It proposes a
default name and directory for the trigger script.

2 Type TUT_TRIG.SQL in the File Name box.

3 Type Examples in the Directory box.
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Generate a script for triggers and procedures

4 Select the generation parameters shown below.

These parameters generate all triggers and procedures.

&~ For a complete description of generation parameters, see

PowerDesigner DataArchitect User's Guide

Parameters for Sybaze S50L Anywhere 5.5
Databaze nams:  TUTORIAL
File name: ITut_trig.sqI V' Ore file only
Directory: IE:\F’WHS\F’DE\EHampIes
Qwiner: I[j_\"] j
Trigger and procedure generation | Dp[igngl
— Triggers Tables Frocedures
o« Al & Al tables & Al procedures
" By default  List 2  List Il
 User-defined
— Orders to be generated
¥ Create procedure ™ Drop procedure
¥ Create trigger [~ Drop trigger
W For ingert _I
¥ For update _I = Open database
¥ For delete _I 7| Clase database
— Ermor meszages
@ Standard " User-defined _I
Generate gcripk I Create iggers | Cancel | Help |

5  Click the Options tab.
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7

Select the options shown below.

In the Referential Integrity groupbox, you select the Trigger radio
buttons. This indicates that you want to generate referential integrity

triggers, as opposed to declarative referential integrity.

Parameters for Sybaze S50L Anywhere 5.5

Databaze name:  TUTORIAL

File name: Itut_trig. 2| V' Ore file only
Directory: IE: WPR SWPDEVERAMPLES
Owner: I[None] j

Trigger and procedure generation  Options |

I General
Text: ™ Uppercase ™ Lowercase ™ Mo accent
Lse: & Codes © Mames ¥ Owner prefis
Character set: & windows [8MSI] € DOS [DEM)
¥ Add titles [~ Automatic Archive
— Referential integrity
Update parent ———— Delete parent
Trigger Declarative Trigger Declarative
Restrict: (o (e Restrict: [ (e
Cascade: () (o Cascade: (G (o
Set null: o (o Set null: (o (o
Set default o e Set default o e

Generate gcripk I Create iggers | Cancel |

Help |

Click the Generate Script button.

The Messages window displays the generation messages.

EI@' Eraze | Cancel |

Result: 0 eror(s), 9 warning(s). ;I
The model is comect, no emrors were found,

Generate triggers for "'Tutorial”...
Triggers have been generated in the file "tut_trig.zgl".

Uszage:
[1) Start the S0L interpreter; 1S0L
[2] Select the item "Options" of the menu "Cormmand"
[3] Change "Cammand Delimiter’ to / _I
[4] Open the zcript tut_trig.sql from the directory C:APWRSSPDENE xamples
[6] Execute the script
[6] Restore ""Command Delimiter'' ta ;

o
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Generate a script for triggers and procedures

A Confirmation box asks you if you want to view the script.
PowerDesigner - Confirmation

@ Generation successful. Do pou want ta view the generated script?

Mo |

8 Click Yes.

A window displays the generated script. The script starts with the
HISTORY_PROC stored procedure that you defined.

B tut_tiig_sql - Notepad [_ (3] x]
File Edt Seach Help

%% =================================================s========== IEJ
%% Database name: TUTORIAL

%%  DBHMS name: Sybase SQL Anywhere 5.5

%% Created on: 3/28/97 5:43 PH

%% =================================================s==========

create procedure HISTORY_PROC ()
begin

—-- clean up the table

delete from HISTORY;

-- Ffill it again from scratch
insert into HISTORY{TITLE_ISEM, TITLE_PRICE, TITLE_TEXT, TOTAL_SALES
select T.TITLE_ISBN,T.TITLE_PRICE,T.TITLE_TEXT,sum{S.3ALE_RAMDUNT)
from SALE S, TITLE T
where T.TITLE_ISBH = S.TITLE_ISBHN
group by T.TITLE_ISBM, T.TITLE PRICE, T.TITLE_TEXT;

end

/

% Before update trigger "tub_author™ for table "AUTHOR"
create trigger tub_author before update of AU_ID

“| | H 4

9  Select File>Exit to close the script window.

10 Click OK to close the Messages window.

What you learned In this section, you learned how to:
+ Select options that will generate triggers

+ Generate a script for triggers and procedures
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CHAPTER 19
Generating a Database Script

You can generate a database directly from a PDM, or you can generate a
database script which you can run in your DBMS environment. You create a
script for a particular target database.

The generation parameters which are available depend on the target database
you select. By default, the target database is the one you select when you
open the PDM, but you can select another before generating the script.

In this chapter you will:
+ Attach an expression to a business rule
+ View a validation rule

+ Generate a database creation script

How long will it take?
About 5 minutes.
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Attach an expression to a business rule

Attach an expression to a business rule

178

Where you are

Chapter 19 Generating a Database Script
® Attach an expression to a business rule

View a validation rule

Generate a database creation script

You will create a validation rule that controls values of columns in the
ROYALTY table. You will do this by attaching a server expression to a
business rule that is already attached to a table.

1 Select Dictionary>List of Business Rules.

The List of Business Rules appears.

2 Click the Royalty Ranges line in the list.

An arrow appears at the beginning of the line.

List of Business Rules [ x|
Mame | Cods | Type E|U|N|i|
1 |Advance ADWANCE Farmula ECFT
2 |Author Pemcent AUTHOR_PERCENT Walidation B
3 |Author Sales AUTHOR_SALES Fact (3l
4 |Royalties ROTALTIES Formila FECFT
+ |Ropalty Ranges [EROYALTY_RAMGES Validation  [ECTC T
E_ |Salesin Stores SALES_IN_STORES Defirition  [®C T [T
Mew I Delate | NI 4 I 3 I >I| Sortby: ¢ Name & Code
Label: I

Define | Attach | QK I Cancel Help
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3 Click the Define button.

The definition of the business rule appears. The description appears in

the upper part of the dialog box. The Server radio button is selected, but
the expression pane is empty.

4 Type the following SQL command in the Expression pane.
ROYALTY.ROY_LORANGE + 1000 <= ROYALTY.ROY_HIRANGE

Business Rule Definition [ %]

Mame: [Fiopally Flangss =] tode [ROVALTY_RANGES [-

Tupe: IVaIidation 7] Label |

Diescription:

IThe low range For an amount of ropalties must be at least 1000 less than the the high range. ;I
-

Expression; ¢ Clisnt % Server

ROTALTY.ROY_LORANGE + 1000 <= ROTALTY.ROY HIRANGE ;I
-

Zoom |Eﬁtended| &nnotatel Attach | ak I Cancel | Help |

5 Click OK in each of the dialog boxes.

179



View a validation rule

View a validation rule

Where you are

Chapter 19 Generating a Database Script

Attach an expression to a business rule
» View a validation rule

Generate a database creation script

You will view the validation rule that you just created as it relates to the table
ROYSCHED.

1 Double-click the ROYSCHED table symbol.
The table property sheet appears.

2  Click the Check button.

The table check parameters dialog box appears. The validation rule that
you defined appears in the server validation rule pane.

Table Check Parameters

Table : ROYSCHED [Raoyaly Schedule]

Constraint name: ™ User-defined
Mo, Mame Code Type
1 Fioyalty Fanges ROYALTY_RAMGES W alidation

Server validation rle: & Default " Additional
ROYALTY ROY_LORANGE + 1000 <= ROYALTY.ROY_HIRA&NGE ;l
Client validation rule: & Default = Additional

Bules | Extended | Z000T I ak. I Cancel | Help I

3 Click OK in each of the dialog boxes.
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Generate a database creation script

Where you are
Chapter 19 Generating a Database Script
Attach an expression to a business rule
View a validation rule

®» Generate a database creation script

1  Select Database> Generate Database.

The Parameters for Sybase SQL Anywhere dialog box appears. It
displays the generation parameters. Certain parameters are already
selected.

2 Type TUTORIAL.SQL in the File Name box.
3 Type EXAMPLES in the Directory box.

4 Select the generation parameters shown below.

Parameters for Sybase 50L Anywhere 5.5
Databaze name:  TUTORIAL
File name: Icrebas. El ¥ 0One file orly
Directory: IC:\P\v\-"HS\F‘DS\EHampIes
Owner. I[None] j
Schema | Databasel Dptionsl
i Tables o Miews |
ot | & Alviews © List |
v Create table V¥ Create index [ Create view
¥ Primary key ™ Primary key = Camment
= Eareian kew ™ Fareign key ™ Drap view
= Decl, inteari _I [~ Alernate key
¥V Altemate key ¥ Other indexes — Columns
¥ Check ¥ Physical options ¥ User-defined type
¥ Physical options ™ Dropindex v Default value
¥ Begin script V¥ Check.
W End zripk ™ Comment
[ Comment
™ Drop table

Generat3§criptl Cleatedatal_:asel Cancel | Help |
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Generate a database creation script

& For a complete description of database generation parameters, see
PowerDesigner DataArchitect User's Guide

5  Click the Generate Script button.
The Messages window displays the generation messages.

v Messages [_ O]

EI@' Erase | Cancel |
=
Checking References. ..
Result: 0 eror(z), 0 waming(s).
The model is comect, no erars were found,
Generating script for ' Tutorial..
Generation successhul, _I
Uszage:
[1) Start the SOL interpreter: 1S0L
[2] Open the zcript Tutorial. 2gl
[3] Execute the script
=

A Confirmation box confirms generation of the script and asks if you
want to view the script.

PowerDesigner - Confirmation

@ Generation successful. Do pou want ta view the generated script?

Mo |
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Chapter 19 Generating a Database Script

6 Click Yes.

A window displays the generated script.

B hutsiisl anl - Hoteposed

e | Geach Hep
Database mamc: TETOALIAL j
DHHS s 2 pbdse SUL Engeherd .5
Erealid &Ec 2re NS BEET PR

iF ealsts{select 1 From sysdonalis where ossain_name- T_DATE) then
#rap datatype T_BATE

rnd LF;
creste databppe T_DATE date

ir emists]erlect 1 Prom sysdonain ehere demaln_nane="T_SHOET_TEST'] Ehe
@rap datatgpe T_SHOET_TEXT
end 1F;

creale databpgs | _SHOED TEST varchar{Zd] 3

iF emintn{select 1 From aysdonsis ehere dsawin_nane="T_LOHE_TEXT'} bhen
dFap datatype T_LDHE_TESRT
el BF:

1 11

7 Select File>Exit to close the script window.

8 Click OK to close the Messages window.

183



CHAPTER 20
Generating a Test Data Script

About test data

About data profiles

Test datais sample data that you can define and generate for one or more
tables in a PDM. When you generate test data, it automatically generates
rows of data in database tables.

Test data is normally used as a development tool in designing data bases.

You can use test data to verify the performance of the database when it is
filled with large amounts of data, or when it is accessed by different
applications or users.

You can generate test data directly from a PDM, or you can generate a test
data script which you can run in your database environment.

You generate test data for a table based on data profildestafprofile is a
named class of data types that has a defined data generation source.

You assign a data profile to one or more columns. Test data is generated for
the columns using the data source defined for each data profile.

In this chapter you will:
¢+ Create data profiles
+ Define an automatic test data generation source for selected data profiles

+ Define afile containing data as a test data generation source for a data
profile

+ Assign data profiles to relevant columns in a selected table
+ Generate a test data script for the table
+ Exit DataArchitect

How long will it take?
About 15 minutes.
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Create data profiles

Create data profiles

186

Where you are
Chapter 20 Generating a Test Data Script

» Create data profiles
Define an automatic test data generation source
Define a file as a test data generation source
Assign data profiles for a selected table
Generate a test data creation script
Exit DataArchitect

You will create two data profiles called Sales and Price, which both have the
class Number. These data profiles will represent columns that have number
data types such as numeric or integer.

You will then create another data profile called Long_Text, which will have
the class Character. This data profile can represent any column that has a
character data type.

1  Select Dictionary>Profiles > List of Profiles from the menu bar.

The List of profiles appears. By default an arrow appears at the
beginning of the first line.

2 Type Sales in the first line of the Name column.

This is the name of the data profile.
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Click the Code column.
Click the J button that appears in the Code column.

This sets the code equal to the name.

Click the Class column.
Click the =] button that appears in the Class column.

The Class dropdown list appears.

Select Number from the dropdown list in the Class column.

List of Profiles E
MName | Code | Clazs | N lil
Sales SALES Mumber (-

LT

Mew | Delete | ﬂil_blll Sortby © Name & Code ¢ Class

Label: I

" Generation source

& putomatc  C Fle | Cls | o opec_ |

Eropertiesl Attach | Desgribel Annoﬁatel ak I Cancel | Help |

This defines the Number class for the data profile Sales.

Click the New button.

An arrow appears at the beginning of the first blank line in the list.

Repeat steps 2 to 6 to create the following data profiles with their

corresponding classes:

Data profile |Class

Price Number

Long_Text Character
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Create data profiles

The List of Profiles should appear as shown below:

List of Profiles [ %]

Name | Code | Class N[=]
1 5 ales SALES Nurnber E3
2 |Piice PRICE Humber [
=+ |Long Text LOMG_TE=T Lharacter Hr
Mew | Delete | ﬂil_blil Sartby: © Mame & Code ¢ Class
Label: |

" Generation source

& putomatc  © Fle | AT ~ ooec_ |
Eropertiesl Attach I Desgibel .&nnoﬁatel ak. I Cancel I Help |

8 Click OK.
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Define an automatic test data generation source

Where you are
Chapter 20 Generating a Test Data Script
Create data profiles

=® Define an automatic test data generation source
Define a file as a test data generation source
Assign data profiles for a selected table
Generate a test data creation script
Exit DataArchitect

To generate test data you need to define a data source for each data profile.
PowerDesigner can generate test data automatically, using generation
parameters that are defined for each data profile.

You will define automatic test data generation sources for the data profiles
Sales and Price.

1 Select Dictionary>Profiles > List of Profiles from the menu bar.

The List of profiles appears.

2  Click the Sales line in the list.

An arrow appears at the beginning of the line.

List of Profiles [ %]
Name | Code | Class N[=]
1 Long_Text LOMG_TEXT Character |; I
2 |Piice PRICE Humber [E3(
+ |Sales [EI54LES Humber [E3

d

Mew Delete | ﬂil_blil Sartby: © Mame & Code ¢ Class

Label: |

" Generation source

& putomatc  © Fle | AT ~ ooec_ |
Eropertiesl Attach I Desgibel .&nnoﬁatel ak. I Cancel I Help |
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10

Select the Automatic radio button from the Generation Source group box.

Click the Properties button.

The profile Number dialog box appears.
Select the Random radio button.
Type 1in the From textbox and 100000 in the To textbox.

You define a range of between 1 and 100,000 for the random test
numbers that will be generated for the data profile Sales.

Profile: Sales [Number]
 Walues
— Tupe
@ Random  Sequential
— Range
Erom |1 ta [100000
Step: I

 Decimal Mumbers
[ Generate decimal numbers

Decimal digits number: I_

ak I Cancel | Help |

Click OK.

You return to the List of Profiles.

Click the Price line.

An arrow appears at the beginning of the line.

Select the Automatic radio button from the Generation Source group box.

Click the Properties button.

The profile Number dialog box appears.



Chapter 20 Generating a Test Data Script

11 Select the Random radio button.

12 Type 5 in the From textbox and 50 in the To textbox.

13 Select the Generate decimal Numbers checkbox.
Click the Decimal Digits Number textbox.
Type the number 2 in the Decimal Digits Number textbox.

You define a range of between 5.00 and 50.00 for the random test
numbers that will be generated for the data profile Price.

The Profile Number dialog box should appear as shown below.

Profile: Price (Number)

i Walues
— Tupe
& Random " Sequential

— Range
Fram |5 o IED

Step: I

 Decimal Mumbers

W Generate decimal numbers

Decimal digits number: |2_

ak I Cancel | Help |

14 Click OK.

You return to the List of profiles.

15 Click OK.
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Define a file as a test data generation source

Where you are

Chapter 20 Generating a Test Data Script

Create data profiles

Define an automatic test data generation source
® Define a file as a test data generation source

Assign data profiles for a selected table

Generate a test data creation script

Exit DataArchitect

You can specify a CSV format file which contains data, and use the data as a
test data generation source for a data profile.

You will define a CSV file as a test data source for the data profile
Long_Text. The directory TESTDATA in the PowerDesigner path contains a
number of CSV files that can be used as test data generation source files.

1 Select Dictionary>Profiles > List of Profiles from the menu bar.

The List of profiles appears.

2 Click the Long_Text line in the list.

An arrow appears at the beginning of the line.

3 Select the File radio button, from the generation Source group box.

4  Click the = button that is next to the File radio button.

A standard file selection box appears.

5 Select the directory TESTDATA in the PowerDesigner path.
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Select the file SIC_GRP.CSV
This file contains data which classifies a number of businesses and
industries into categories based on their type of commercial activity.
This type of data, which is both general and structured, is a useful data
source for columns that require a character string of meaningful data
with a limited length.
Choose a File HE
Laak in: IaTestdata j il IT
address.cav countiy.cey Iname. csv shatecod.c
areacod?. cav district.cav miMme. Gsv
areacodB.csv fname.csv sic div. csv
areacode. cav job.cav ;
city.csv Iatin.csv ) smoney.cav
COMp.CaY Iniey. csy shate ooy
a| | >l
File name: Isic_glp. cay oK I
Files of type: I"_csv j Canicel |
7  Click OK.
You return to the List of Profiles.
8 Click OK.
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Where you are

Chapter 20 Generating a Test Data Script

Create data profiles

Define an automatic test data generation source

Define a file containing data as a test data generation source
® Assign data profiles for a selected table

Generate a test data creation script

Exit DataArchitect

You will assign a data profile to each column for the table History in the
PDM model. For this tutorial you will assign data profiles from the Table
Properties sheet. However, you can also assign data profiles from the List of
domains and List of columns.

&~ For information on selecting a data profile for a domain, see the
PowerDesigner DataArchitect User's Guide

1 Double-click the History table symbol.

The Table Properties dialog box appears.
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2  Click the Fill button.

The Fill Parameters dialog box appears. Title ISBN is the first line in the
list. It is selected by default. The Profile dropdown list is greyed because
Title ISBN is a foreign key. You can not assign a data profile to a
foreign key column. It automatically takes the data profile of the primary
key in the parent table.

Fill Parameters of Table: History [ %]
Digplay: & Mame " Code
Column | DataTwpe | Nulval [ Distinctal | Length [M[U[F[<]
* e [56M ichail10) 0% 100% 10 | mall i o
2 |[Title Price numeric(#.2) 0% 100% g rrr
3 |Title Text warchar(80] 0% 100% &0 rrr
4 |Total Sales numeric(2,2) 0% 100% g O O
L ]
 Column fill parameters
HNull values: Iljz vI Distinct values: I‘IEIEIZ 'l Awerage length: I‘ID
 Test data parameters
Brofile:  [<Dindefined> o

aK I Eancell Help |

3 Click the Title Price line in the list.

An arrow appears at the beginning of the line. Title Price has the data
type NUMERIC(8,2). Based on this data type, and the sort of data that
you want to generate for the column, you will assign the data profile
Price to this column.
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4

Select Price from the profile dropdown list.

The data profile Price is assigned to the column Title Price.

Fill Parameters of Table: History [ %]
Digplay: * Name ¢ Code
Column | DataTwpe | Nulval [ Distinctal | Length [M[U[F[<]
1 Title 1SEM char(10) 0% (#1003 [#[10 el il
+ |Title Price nurmeric(3,2] 0% [®100% [#a rrr
3 |Title Text warchar(80] 0% [®100% [#s0 rrr
4 |Total Sales mumeric]8,2) 0% [®[100% 3 O O
LIRVLAN])
 Column fill parameters
Mull values: Iljz - I Distinct values: I‘I [ilES - l Awerage length: IB
 Test data parameters
Profile: | _I

aK I Eancell Help |

Click the Title Text line in the list.

An arrow appears at the beginning of the line. Title Text has the data
type VARCHAR(80). Based on this data type, and the sort of data that
you want to generate for the column, you will assign the data profile
Long_Text to this column.

Select Long_Text from the Profile dropdown list.

The data profile Long_Text is assigned to the column Title Text.
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7  Select the column Total Sales.

An arrow appears at the beginning of the line. The column Total Sales
has the data type NUMERIC(8,2). Based on this data type and the sort of
data that you want to generate for this column, you will assign the data
profile Sales to this column.

8  Select Sales from the profile dropdown list.

9 Click OK.

You return to the Table Properties dialog box.

10 Click OK.
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Where you are
Chapter 20 Generating a Test Data Script
Create data profiles
Define an automatic test data generation source
Define a file as a test data generation source
Assign data profiles for a selected table

®» Generate a test data creation script
Exit DataArchitect

You will generate a test data script for the table History. You can execute a
test data script in a database that contains the same tables that you use to
generate the script.

1  Select Database> Generate Test Data.

The Test Data Generation dialog box opens to the Parameters page. It
displays the test data generation parameters. Certain parameters are
already selected.

2 Type INSERT.SQL in the File Name box.

3 Inthe Directory box, specify the EXAMPLES directory in the PowerDesigner
path.

4 Select the List radio button and click the -2l button.
A List of Tables appears.
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5

6

From the Available pane, select History and click the Add button.

History appears in the Selected pane.

List of Tables
Axailable Selected

AUTHOR HISTORY

DISCOUNT Al > |

FICTURE

PUBLISHER Add afl »» |
ROYSCHED
SALE

STORE Hemaove << |

TITLE

TITLEAUTHOR Remove all << |

Cancel |

Click OK.

You return to the Parameters page of the Test Data Generation dialog
box.

Select the Delete Old Data Checkbox.

All the existing data in the table you are using to generate test data will
be deleted and replaced by the test data.

Default Number of Rows
The default number of rows is the number of rows of test data that
will be generated for tables, that do not have a value defined in the
Number of Rows page of the Test Data Generation dialog box. Ypu
will use the default value 10, which means you will generate ten rpws
of test data for the table History.
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8  Select Price from the Default Number Profile dropdown list.
Select Long_Text from the Default Character Profile dropdown list.

The default data profiles are the profiles that will be automatically
assigned to any column with the appropriate data type, that does not have
a data profile already assigned to it.

You do not need to change the <Undefined> option for the Date profile,
because the table History does not have a column that takes a Date data
profile.

The Parameters page for the Test Data Generation dialog box, should
appear as shown below.

Test Data Generation
Eile mame: |Insert.sq| ¥ Ore file anly
Directory: IE:\F’WHS\F‘DB\ExampIes

Parameters | Murnber of Howsl Dptionsl

— Tables

Al &t 7

~ Delete old data

Default number of ravs: I‘I 0

Default humber profile: Ih
Default character profile: Im
Default date profile: Im

Generate Script | Create Test Datal Cancel | Help |

9  Click the Generate Script button.

A Confirmation box asks you if you want to delete all old data.

PowerDesigner - Confirmation [ x|

@ Are pou sure you want ta delete all old data’?

Cancel I

200



Chapter 20 Generating a Test Data Script

10 Click OK.

A confirmation box confirms generation of the script and asks if you
want to view the script.

11 Click Yes.
A window displays the generated script. The title of each column in the
table History appears after the insert command.

12 Scroll to the right to view the generated test data.

Be EM §esch Hen

uslues [ 'Sdmini=tr', 7 .68, 'WHuxcellsesus =ervices |, BEEFW]

values [Catian of ', 0.5, "Hiscellamow relail’, 8929);

uaplues [‘ecenmmdc' | 2E.0%, "Fernltere asd Filotwres', 43965

values [“pregrams’, D8P, "Heawuring”, BF7eN);

valiws | ‘@dninistr®, 1477, ‘Coal mining', SPO30;

uslus [‘stdan oF', 2555, "Hetsl wining', PFI1&);

values [Cenvlrenme, 2% 801, ‘Smcesenl a0l cecreablon seredoes |, a9209);
uglues ['atsl qual', 3,55, 'Hogell@mesns repalr sevvices', 57980 ;
values [“thy and h', WB.&1, ‘Building naterdslu”, SE1);

uplues [Ceusing pe', WB.4A, ‘Tewtdile sill praduscts', ST930);

;I [

13 Select File>Exit to close the script window.

14 Click OK to close the Messages window.

15 Click Cancel to close the Test Data Generation dialog box.
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Where you are
Chapter 20 Generating a Test Data Script
Create data profiles
Define an automatic test data generation source
Define a file as a test data generation source
Assign data profiles for a selected table
Generate a test data creation script

» Exit DataArchitect

You will close the PDM and exit DataArchitect.

1

Select File> Save from the menu bar.
This saves the PDM.

Select File> Close from the menu bar.

This closes the PDM window.

Select File>Exit from the menu bar.

You exit the DataArchitect application.




Glossary

alternate key

business rule

clustered index

column

Conceptual Data

Model (CDM)

constraint

data item

data source

data profile

domain

entity

Column or columns whose values uniquely identify a row in the table and are
not primary key columns

Written statement specifying what the information system must do or how it
must be structured to support business needs

Index in which the physical order and the logical (indexed) order is the same

Data structure that contains an individual data item within a row (record),
model equivalent of a database field

Entity-relationship diagram that models the information system without
considering the details of physical implementation

Named check that enforces data requirements, default values, or referential
integrity on a table or a column

Elementary piece of information

Identification of the data to access, its operating system, DBMS, and network
platform

Named class of data types that has a defined data generation source, and can
be assigned to one or more columns.

Set of values for which a data item is valid

Person, place, thing, or concept that has characteristics of interest to the
enterprise and about which you want to store information
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Glossary

entity attribute

extended attribute

foreign key

4GL

index

Inheritance

ODBC

ODBC driver

Physical Data
Model (PDM)

primary key

property sheet

reference

referential integrity

204

Elementary piece of information attached to an entity

Additional information that completes the definition of an object for
documentary purposes or for use by an external application such as a fourth-
generation language (4GL)

Column or columns whose values depend on and migrate from a primary key
in another table

External application that uses a fourth-generation language, usually to
generate a client/server application

Data structure that is based on a key and that speeds access to data and
controls unigue values

Special relationship that defines an entity as a special case of a more general
entity

Open Database Connectivity (ODBC) interface which gives PowerDesigner
access to data in database management systems (DBMS)

Part of the Open Database Connectivity (ODBC) interface that processes
ODBC functions calls, submits SQL requests to a specific data source, and
returns results to the application

Table-reference diagram that models the information system including the
details of physical implementation

Column or columns whose values uniquely identify a row in a table
Window that displays the properties of an object
Link between the primary key and the foreign key of different tables

Rules governing data consistency, specifically the relationships among
primary keys and foreign keys of different tables
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relationship

storage

table

tablespace

trigger

unique index

view

Named connection or association between entities

Named partition that stores tables and indexes on a storage device
Collection of rows (records) that have associated columns (fields)
Named partition that stores tables and indexes in a database

Special form of stored procedure that goes into effect when you insert, delete,
or update a specified table or column

Index in which no two rows can have the same index value, including NULL

Alternate way of looking at the data in one or more tables. Usually created as
a subset of columns from one or more tables
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add
column 129, 155
data item to entity 55

graphic 91
object to submodel 82
table 127
title box 94
adjust
display 21
align
symbol 97
alternate key 203
create 138
index 138
arrange
symbol 97
assign
data profile 185, 194
attach

business rule to entity 47, 66

check parameter to domain 43

data item to domain 41

expression to business rule 178
attribute 204

create 59

define 54

entity 47

extended Seeextended attribute

B

business rule 27, 203
attach expression 178
attach to entity 47, 66
create 29
define 27
fact 27
formula 27
sort 31

business rulécontinued)
validate 27

C

cardinality 69
one to many 69
relationship 69

CDM 203
check parameter 27
close 108
define 3,22
display 93
open 20
option 22
preference 22
property 24

save 26, 108
center

model 100

symbol 87

check parameter 27

attach to domain 43
close

CDM 108

PDM 107, 202

submodel 91
code

data type 33
color

default 95

title box 95

window 96
column 203

add 129, 155

calculate 155

create 133

entity 38

foreign key 125

primary key 125
constraint 203
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create
alternate key 138
business rule 29
column 133
dataitem 37
data profile 186
domain 32
entity 49, 53
entity attribute 59

extended attribute 160

index 135, 138
inheritance 86, 91
primary key 135
procedure 170
reference 144
relationship 71
submodel 78
table 125
trigger 168
view 149, 150
customize
view 151

D

data item 27, 203
add to entity 55
attach to domain 41
create 37

data profile 203
assign 185, 194
automatic data source
create 186
define 185

data source 203

data type
code 33
default 36

DataArchitect
install 7
open 12

database
creation script 181
generate 177,181

DEF file 103
default

data type 36
define

business rule 27
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189, 192

define(continued)
CDM 22
data item 27
data profile 185
domain 27
entity 47

extended attribute 159

index 125
inheritance 85, 88
option 22,120
PDM 115, 122
preference 22,120
property 24,122
reference 143, 145

referential integrity 143, 147

relationship 69, 73
test data 185

delete
object 18
symbol 18
designate
identifier 62
detach
symbol 18
display
adjust 21
CDM 93

organize 93

preference 22

relationship 75
domain 27, 203

attach check parameter

create 32

dataitem 41

E

entity 203
add 55
attribute Seeattribute
child 85
column 38
create 49, 53
define 47
identifier 47
parent 85

EXA file 165

expression
attach 178
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extended attribute 204
create 160
define 159
export 165
modify 163
save 165
value 163

F

foreign key 204
column 125
index 125
reference 143
referential integrity 143

G

generate
automatic test data 189
database 177,181
PDM 104
test data from file 192
test data script 198
trigger 168
trigger script 173
global model 77
graphic 91
graphic
print 102

I

identifier
designate 62

index 204
alternate key 138
clustered 203
create 135,138
define 125
foreign key 125
primary key 125, 135
search 125
uniqgue 205

inheritance 204
create 86, 91
define 85, 88

inheritance(continued)
mutually exclusive 85
property 88

install
DataArchitect 7

integrity Seereferential integrity

item Seedata item

K

key Seealternate key, foreign key, or primary key

L
language
fourth-generation 204
M
model

center 100

print 102
modify

extended attribute 163
move
symbol 51

N

name
identifier 62
reference 145
relationship 73

O

object
add to submodel 82
delete 18
select 16
ODBC 204
driver 204
open
CDM 20
PDM 117,118
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option
CDM 22
define 22,120
PDM 120
relationship 73
organize
display 93

P

palette
tool 14

parameter Seecheck parameter

PDM 3, 111, 204
close 107, 202
define 115, 122
denormalize 125
file 114
generate 104
generate from CDM 103
open 117,118
option 120
preference 120
property 122
save 107,124, 202
tool palette 14

preference
CDM 22
define 22,120
display 22
PDM 120

primary key 204
column 125
create 135
index 125, 135
reference 143
referential integrity 143

print
graphic 102
model 102
procedure
create 170
script 173
stored 170
profile Seedata profile
property
CDM 24
define 24, 122
PDM 122

210

property(continued)
reference 145
relationship 72
table 127

property sheet 204

Q

query
SQL 158

R

reference 204
create 144
define 143, 145
foreign key 143
name 145
primary key 143
property 145
table 144

referential integrity 204
define 143, 147
foreign key 143
primary key 143
trigger 167

relationship 205
cardinality 69
create 71
define 69, 73
dependent 69
display 75
name 73
one-to-many 71
optional 72,73
property 72
straighten 99

rule

business Seebusiness ruler validation rule

S

save
CDM 26, 108
extended attribute 165
PDM 107, 124, 202



script

create database 177
create trigger 167
generate test data 198
generate trigger 173
procedure 173
trigger 173

view 198

select

object 16
tool 16

sort

businessrule 31

SQL

query 158
view 158

storage 205
submodel 77

add object 82
close 91
create 78

symbol

align 97
arrange 97
center 87
delete 18
detach 18
move 51

table 205

add 127
create 125
property 127
reference 144

tablespace 205
template

trigger 167

testdata 185

assign data profile 194
assign profile 185

automatic generation source 189

create profile 186
data profile 185
file generation source 192

generate data source 189, 192

generate script 198

title box
add 94
color 95

tool
identify 14
name 14
palette 14
release 16
select 16

tool palette
PDM 14

trigger 167, 205
create 168
referential integrity
script 167, 173
template 167

Vv

validation rule
view 180

view 205
create 149, 150
customize 151
define 149
SQL 158
validation rule 180

w

window
color 96
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